X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Search provider hijacked to search-results.com

Posted

I'm unable to resolve this after 2 hours of trying solutions on the web. I have tried going to about:config and changing the keyword to the google address url, and it is the google url, but still my default engine is search-results.com. (Why this has to be so difficult in Firefox is beyond me). I have run multiple anti-virus and anti-spyware programs and nothing is detected. I'm now officially giving up on this cr*ppy browser. I know it's free software and maybe I shouldn't complain, but Firefox is crashing so often (with the "cute" error message "snap!") and then there is this unsolvable problem that you can't set your default search provider that in my book Firefox is actually malware.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

(edited for readability - c)

Modified by cor-el

Question owner

@madperson: Thanks for trying to help. I don't have any toolbars in Firefox add-ons or Windows. No spyware, viruses, or toolbars are detected by Malwarebytes, Super Antispyware, or MS Security Essentials. I already uninstalled Firefox, and I don't intend to install it ever again, so I don't need any more help.

In the future, I plan only to use browsers that allow me to change the default search provider without having to hack the settings file. This currently includes all browsers except Firefox.

One embarrassing thing about my original post: I think the "cute" error message "aw snap" is actually a Chrome error message, not a Firefox error message. But I stand by my statement that Firefox is buggy and crashes more often than other popular browsers.

Check out this article about Firefox by John Dvorak: http://www.pcmag.com/article2/0,2817,2404463,00.asp

MikeMacairan 0 solutions 1 answers

Helpful Reply

I had that same problem and even though I would change my default search engine in about:config, typing into my address bar would still bring me to searchresults.com.

I then looked in Control Panel, Programs and Features (may be 'add remove programs,' depending on your version of Windows) and found searchresultsqu installed there. Once I removed it, my default search engine reverted back to Google.

I wish I were an expert hacker so that every time I get hijacked like that, I could go to the place I'm being redirected and wreak havoc on them.

Question owner

I appreciate your response, Mike. In my case though I didn't have any "searchresults" or other similar malware listed under "remove programs". I don't have any toolbars either.

What annoys me the most is that it's so difficult to change the search provider back to google in Firefox. You literally have to be able to write code and hack the about:config file. In my case even this didn't help though. In all other browsers the search provider is easy to change in settings. It should also be possible to LOCK the search provider and home page so that these cannot be changed by malware. To my knowledge, no browser let's you lock them.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

if you want to use firefox again, it would probably be best to start fresh & reset the browser...