X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop my searches from redirecting to search-results.com?

Posted

So, I've already tried going into about:config and resetting or changing the keyword.URL to default or google as was suggested in other questions dealing with the same issue. I think that this problem arose when a friend wanted to watch something on veoh and it said it needed a plugin. When she downloaded it, it put a bunch of stuff on my computer which I removed. Or so I thought. I can't find any trace of the stuff now, but when I first opened firefox after this, my home page had been changed to the search-results.com homepage so I changed it back thinking everything would be good. However, now when I search in the bar provided on the default home page or just in the address bar it redirects my search to search-results.com instead of google. But just going to and using google is fine. I also went and checked on internet explorer and it had search-results as well which I was able to get rid of and google chrome had said something had tried to change settings but was blocked. The only thing that I can't seem to get rid of it in is my firefox! I even tried uninstalling and reinstalling firefox and it's still there. Also I did a scan with malwarebytes and it removed some things but I don't know if they were related in anyway to this problem. Thanks!

Additional System Details

Sites Affected

http://

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19

More Information

Eray Gezer 0 solutions 1 answers

Helpful Reply

Remove the adware software you have. I mean, adware softwares are small softwares which installs toolbars and changes search defaults. After that, try the "about:config" way. It must work. If it doesn't work, try to clean your history and regedit.exe and try again.

Modified by Eray Gezer

Tobbi
  • Moderator
67 solutions 450 answers

Hey,

please read the Troubleshoot Firefox issues caused by malware article and execute the steps mentioned therein.

--Tobbi

sriram15690 0 solutions 1 answers

Helpful Reply

Step 1 :In the Location bar, type about:config and press Enter.

       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. 

Step 2 : In the Search field, type keyword.enabled.

   Double-click the keyword.enabled preference to set its value to false. 
       https://support.mozilla.org/media/uploads/images/2012-09-11-12-48-42-2b9b31.png

Step 3 :Changing the Internet Keyword service

You can specify any valid URL to perform the Internet Keyword searches by modifying the keyword.URL preference in the about:config page:

   In the Search field, type keyword.url
        https://support.mozilla.org/media/uploads/images/2012-09-11-12-57-50-d8fea1.png
   To use Google search, right-click on keyword.URL and select Reset. 
   To use Yahoo!, set keyword.URL to http://search.yahoo.com/search?p=,
   For Bing, set it to http://www.bing.com/search?q= . Other services maybe specified similarly.
   

Note: The default Google search is encrypted to prevent eavesdropping. Switching to another search provider removes this protection.

http://www.google.com/#sclient=psy-ab&hl=en&site=&source=hp&q=

Now the search results come up in Google not in this other annoying search engine

Modified by sriram15690

seclu-peclu 0 solutions 1 answers

November, 2012

Actually, the problem seems to have become a bit more entrenched.

So, now this 'malware (whatever its source is)' seems to be updating many more entries in the config file. If you want to retain the search functionality in the browser address bar, you can follow the below listed steps.

So ,here go the steps again -

Step 1 - Goto the browser address bar and type in 'about:config' . Press 'Enter' - Click through to the next page

Step 2 - In the Search field on top - Key in 'keyword.url' - Right-click - Select 'Modify' - Change to the search-engine that you want - as listed in the posts above

Step 3 - In the Search field on top - Key in 'browser.search' . RESET the values (by right clicking) of -

a) browser.search.defaultenginename

b) browser.search.order.1

The search function started working for me with my preferred search engine after these steps. Hope this helps.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can also try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart then see:

(locking thread because of age)