X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want my home page to be the firefox symbol with the google search in the center of the page. currently I have to go to the upper right hand conner to search

Posted

I want my home page to be the firefox symbol with the google search in the center of the page. currently I have to go to the upper right hand corner to search. If i type anything in the box in the center of the page and hit enter ...................nothing happens.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • iTunes Detector Plug-in
  • Google Update
  • 5.1.10411.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

please try the following steps in order to restore the search function on the default homepage:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


Also check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

  • browser.search.defaultenginename