Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Just downloaded Firefox 18.0.1 and no longer have functionality in Yahoo! Mail. Full functionality remains in Internet Explorer 8 and Google Chrome.


I just downloaded Firefox 18.0.1 and can no longer compose, forward or reply to email messages in Yahoo! Mail. Yet, full functionality remains while using Google Chrome and Internet Explorer 8.

Chosen solution

It's AVG.

I just went through a check and I could use compose only when AVG Security Toolbar was disabled. I like that extension, so I'll just use Another Browser to send the rare Yahoo e-mail.
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • npsitesafety
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin


  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

I am currently running Windows XP Professional on a Fujitsu Lifebook Notebook PC with 1.5 Gb RAM and 60Gb hard drive.

  • Moderator
41 solutions 524 answers

Some users have reported this problem as a result of the Ghostery extension. If you have this installed, go to Yahoo mail and choose "edit blocking options" and then "Don't block on this domain."

If not, Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

AlienLanes 0 solutions 2 answers

gosh, sometimes i feel so ALONE in the world, until i met you!!!! New mac mini 10.8.2 bought 2012/11/20. firefox worked fine until 2013/01/day?

yahoo mail can't reply or compose. i couldn't get submit feedback on mozilla.org. & other websites too, to send in form data. usually can view all websites.

when i tried to submit feedback to mozilla using Safari (since firefox doesn't work sending feedback), mozilla told me to download newest version of Firefox and submit feedback. well i would if i could LOL!

AppleCare doesn't care, they said talk to firefox.

do you use Ghostery? i do.

Question owner

No. I don't use Ghostery. The only add-on I have is the AVG toolbar. And Firefox worked just fine with Yahoo! Mail in previous versions. 18.0.1 still does not work, even in safe mode.

Anfindol 1 solutions 3 answers

I don't use Ghostery either, and suddenly I cannot use compose in Yahoo.

Anfindol 1 solutions 3 answers

Chosen Solution

It's AVG.

I just went through a check and I could use compose only when AVG Security Toolbar was disabled. I like that extension, so I'll just use Another Browser to send the rare Yahoo e-mail.

Question owner

I certainly have the AVG Security Toolbar, and like it as well. But all of a sudden I have full functionality WITH the AVG toolbar. Maybe Mozilla corrected the problem, but my Yahoo! Mail works just as before.

Anfindol 1 solutions 3 answers

I'm still out. Perhaps it is interacting with another add-on. I don't think I care enough to find out; I'll just use IE if I have to send from the Yahoo account.