X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Personal certificate says sucessfully restored after import, but does not display on list of certificates.

Posted

Mac OSx 10.8.2 Firefox 18.0 Firefox -> Prefrences -> advanced -> encryption -> view certificates -> import Select the cert, enter password, then i get this message: Successfully restored your security certificate(s) and private key(s). However the cert does not show up on my cert list, and i cannot access the site that requires this cert.

Cert worked in ver 17 combined with OS 10.7.X Cert works on my win 7 box with firefox 17.0.1

Chosen solution

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • WebEx64 General Plugin Container Version 203
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size_cached_value
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.cisco.com/cgi-bin/login?referer=/en/US/hmpgs/index.html
browser.startup.homepage_override.buildID
20130104151948
browser.startup.homepage_override.mstone
18.0
dom.mozApps.used
true
extensions.lastAppVersion
18.0
gfx.blacklist.webgl.msaa
4
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358440417
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Device ID
0x 166
GPU Accelerated Windows
3/3 OpenGL
Vendor ID
0x8086
WebGL Renderer
Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
AzureCanvasBackend
quartz
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

Question owner

Also works under Win7 with Firefox 18.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Chosen Solution

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Question owner

Thank you Core-el, renaming the cert8.db file worked like a charm!