X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot run Java

Posted

Running Windows7 64-bit and I cannot run Java in FF no matter what I try. I tried uninstalling and re-installing Java (both versions 32 and 64 bit) and uninstalling and re-installing FF 18. I can run java just fine from withing Chrome and IE (both 32 and 64 bit) When I go into about:plugins I don't even see Java listed there. Currently the Java version that is installed is 1.7.0_11-b21 and I have both the 32 and 64 bit versions properly installed.

Any ideas/suggestions will be greatly appreciated.

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • FireFox PDF Architect Previewer

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
PDF Architect Converter For Firefox
1.0
true
FFPDFArchitectConverter@pdfarchitect.com
VDownloader
3.9.1155
true
support@vdownloader.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
849920
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20130104151925
browser.startup.homepage_override.mstone
18.0
dom.max_chrome_script_run_time
0
dom.mozApps.used
true
extensions.lastAppVersion
18.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358369874
places.history.expiration.transient_current_max_pages
104858
plugin.scan.plid.all
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_entering_weak
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA Quadro NVS 160M
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM
256
Device ID
0x06eb
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
DirectWrite Enabled
false (6.1.7601.17789)
Driver Date
5-12-2010
Driver Version
8.16.11.8992
GPU #2 Active
false
GPU Accelerated Windows
0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer.
Vendor ID
0x10de
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer.
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8891 answers

Helpful Reply

hello, in some instances firefox may not be able to detect that the java plugin is installed, because oracle made an error in registering the java plugin for mozilla-based browsers in version 7u10 & 7u11... this will apparently just be fixed with its next release.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8005410

for different workarounds & troubleshooting steps in the meantime see http://kb.mozillazine.org/Java#Windows_installation_issues

Question owner

Many thanks for the info... Will sit tight until Oracle fixes their issue.