X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox typing and cursor are slow upon a normal startup but everything works well when I restart in safe mode?

Posted

When I open FIrefox normally, the cursor movement is very jerky - seems to get stuck on every link. In addition typing in any box is delayed. When I restart with add-ons disabled and in safe mode, the cursor moves fine and typing is normal. I have disabled all my add-ons but that doesn't seem to help as each time I restart, the jerky cursor and delayed typing present again. What is wrong?

When I open FIrefox normally, the cursor movement is very jerky - seems to get stuck on every link. In addition typing in any box is delayed. When I restart with add-ons disabled and in safe mode, the cursor moves fine and typing is normal. I have disabled all my add-ons but that doesn't seem to help as each time I restart, the jerky cursor and delayed typing present again. What is wrong?

Chosen solution

Try to disable hardware acceleration in Firefox.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12020 solutions 111708 answers

Chosen Solution

Try to disable hardware acceleration in Firefox.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/ ---- In Firefox Safe mode these changes are effective: *all extensions are disabled *the default theme is used (no persona) *userChrome.css and userContent.css are ignored *the default toolbar layout is used *the Javascript JIT compiler is disabled *hardware acceleration is disabled *plugins are not affected *preferences are not affected

Helpful Reply

Thanks - that seems to have solved the problem

Thanks - that seems to have solved the problem