X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe Flash, latest version, is hitting the disk hundreds of times per second with disk reads and writes for no obvious reason. Is this normal? If not, ...

Posted

I am running Firefox 18 on Windows 7, all with latest updates. The Adobe Flash plugin (latest version) hits the disk with hundreds of reads and hundreds of writes each second. This seems to start as soon as cnn.com is loaded then as other sites are loaded it just gets worse. Any thoughts on what might be causing this? Is it normal? If not normal, how can I can stop it?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • GEPlugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0 for Mozilla browsers
  • 5.1.10411.0
  • IE Tab Plug-in for Mozilla/Firefox
  • IBM GLOBAL PRINT PLUGIN VER 4.1
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • This plugin allows the user to quickly add people from the BluePages website to their Lotus Notes address book.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{
"application": {
"name": "Firefox",
"version": "18.0",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0/WINNT/en-US/"
},
"modifiedPreferences": {
"accessibility.typeaheadfind.flashBar": 0,
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.history_expire_days.mirror": 180,
"browser.places.smartBookmarksVersion": 4,
"browser.privatebrowsing.dont_prompt_on_enter": true,
"browser.startup.homepage": "http://www.cnn.com/",
"browser.startup.homepage_override.buildID": "20130104151925",
"browser.startup.homepage_override.mstone": "18.0",
"browser.tabs.loadInBackground": false,
"extensions.lastAppVersion": "18.0",
"font.internaluseonly.changed": false,
"gfx.direct3d.prefer_10_1": true,
"network.cookie.prefsMigrated": true,
"network.cookie.lifetimePolicy": 2,
"places.history.expiration.transient_current_max_pages": 104858,
"places.last_vacuum": 1327470543,
"places.database.lastMaintenance": 1357693612,
"privacy.cpd.siteSettings": true,
"privacy.sanitize.timeSpan": 0,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed": false
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 1,
"windowLayerManagerType": "Direct3D 10",
"adapterDescription": "Intel(R) HD Graphics Family",
"adapterVendorID": "0x8086",
"adapterDeviceID": "0x0126",
"adapterRAM": "Unknown",
"adapterDrivers": "igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32",
"driverVersion": "8.15.10.2538",
"driverDate": "9-26-2011",
"adapterDescription2": "NVIDIA Quadro 1000M ",
"adapterVendorID2": "0x10de",
"adapterDeviceID2": "0x0dfa",
"adapterRAM2": "2047",
"adapterDrivers2": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
"driverVersion2": "9.18.13.697",
"driverDate2": "10-2-2012",
"isGPU2Active": false,
"direct2DEnabled": true,
"directWriteEnabled": true,
"directWriteVersion": "6.1.7601.17789",
"webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics Family)",
"info": {
"AzureCanvasBackend": "direct2d",
"AzureFallbackCanvasBackend": "cairo",
"AzureContentBackend": "direct2d"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
}
},
"extensions": [
{
"name": "Collusion",
"version": "0.24",
"isActive": true,
"id": "jid1-F9UJ2thwoAm5gQ@jetpack"
},
{
"name": "IBM Add To Notes Address Book BluePages Plugin",
"version": "1.1.2",
"isActive": true,
"id": "bpaddtonab@firefox-extensions.ibm.com"
},
{
"name": "IBM CCK",
"version": "2.1.10",
"isActive": true,
"id": "IBM-cck@firefox-extensions.ibm.com"
},
{
"name": "IE Tab + (IBM Edition)",
"version": "2.04.20110724.3ibm",
"isActive": true,
"id": "ietab@ip.cn"
}
]
}

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8027 answers

I suppose I would have expected it to try and use ram. I guess you have ruled out that you are out of Memory and the disk is paging.

I know IE uses different software but have you tried and compared that ?

My reply may at least bump the thread and get you an answer.

Question owner

Memory is not a problem: 16 B of RAM. IE does not exhibit this problem with the same web sites loaded.

It appears as if Firefox is running Adobe Flash continuously based upon some content in the web sites that IE, at least, knows not to run Flash continuously.

BTW, by turning off "Take Advantage of Hardware Acceleration" (or some such) in Firefox, the impact of this misbehavior went from major to annoying.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8027 answers

I do not really have any solid suggestions for this but

Flash often causes issues with Firefox. From Flash 11.3 some Windows users were needing to disable Flash's protected mode. Rather a longshot but it may be worth experimenting with the protected mode and trying turning it off.

Potential workarounds would be

  1. look at the pageinfo media. Use Ctrl + I -> |Media| to see what is on the pages
  2. If you do not want that content to play automaticaly consider add-ons like http://noscript.net/ &/or Flashblock or one of the related addons.
cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to clear the Flash local storage and settings.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings
    • Remove a specific domain: Local Storage Settings by site
    • Remove all domains: Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel: