X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox fonts seems less refined and blurry. They are too hazy as compared to Chrome.

Posted

Firefox fonts seems less refined and blurry. They are too hazy as compared to Chrome. I am using Firefox 18, but had same issue with previous versions. This is annoying.

So far i have tried disabling hardware acceleration, fiddling with font settings, enabling/disabling gfx.content.azure.enabled, setting it to true/ false & disabling allow pages to use its own fonts. Nothing helped so far.

Image: http://i.imgur.com/KFhMi.png

Modified by deimo

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • VLC media player Web Plugin 2.0.2
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • Google Update
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

Do you have cleartype and smoothing enabled in windows?

Question owner

Yes, they are enabled.

TomZilla 0 solutions 1 answers

Same here: just switched from Chrome and everything is good, except that the fonts look blurry and unclear on many sites. I'm on Windows 7.

Here's an example of a site where it is annoying (my news site): http://www.theglobeandmail.com/

I have " cleartype and smoothing enabled". For others, I found the instructions on how to verify this here: http://superuser.com/questions/341636/why-windows-7-dialog-fonts-are-not-anti-aliased

Question owner

Most people suggest turning off 'Hardware Acceleration' but that too won't help.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

On Windows XP hardware acceleration shouldn't have that much effect as only Direct 3D is used in some cases.

On Windows XP it is usually caused by ClearType not being enabled system wide for all programs.

  • http://support.microsoft.com/kb/306527 - HOW TO: Use ClearType to Enhance Screen Fonts in Windows XP
  • XP: Control Panel > Display > Appearance > Effects: "Use the following method to smooth edges of screen fonts"