X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 18.0 got a new feature: cursor jumping from link to link, how to disable this?

Posted

windows xp sp3 Cursor is no more following smoothly with mouse movement, it stops and jumps all the time. Feel this annoying and would like to disable the feature but it cannot be found nowhere in tools-options. It just came with update to version 18.0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.35
true
{CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}
Key config
0.3.1
true
keyconfig@petricek.net
Java Quick Starter
1.0
false
jqs@sun.com
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
10240
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
983040
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.startup.homepage_override.buildID
20130104151925
browser.startup.homepage_override.mstone
18.0
browser.tabs.loadInBackground
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
18.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358012054
places.history.expiration.transient_current_max_pages
26578
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Graphics Media Accelerator 500
Adapter Drivers
igxprd32
Adapter RAM
Unknown
Device ID
0x8108
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (0.0.0.0)
Driver Date
4-28-2009
Driver Version
6.14.11.1009
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 9
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 500)
Vendor ID
0x8086
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

Question owner

Did not see this problem with more powerful dual core PC. Perhaps it is some incompatible issue between Firefox 18 and light hardware as Intel Atom for instance?

Question owner

Update 18.0.2 did not solve this problem.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Did you try to create a new profile and check if your current profile is causing the problems, as cor-el said in a previous reply ?

Question owner

No, i did not. So i did it now. Created a new profile, started FF with this new profile... got a browser without my old configurations. Only that sticking cursor movement was there.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Is this with smooth scrolling enabled?

  • Tools > Options > Advanced > General: Browsing: "Use smooth scrolling"
ideato
  • Top 25 Contributor
616 solutions 4260 answers

Try from control panel in xp IF correct the problem : control panel > mouse > pointer options > Visibility > Uncheck "Hide pointer while typing" [ ]

otherwise try a clean reinstall:

Certain Firefox problems can be solved by performing a Clean reinstall.  This means you remove Firefox and any leftover program files and then reinstall Firefox. Please follow these steps one by one:
  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu) and confirm all upcoming messages.
  3. Now, uninstall Firefox by following the steps mentioned in the Uninstall Firefox article.

IMPORTANT: On Windows, the uninstaller has the option to remove your personal data and settings. Make sure that you do not check this option; otherwise all of your bookmarks, passwords, extensions, user customizations and other Firefox user profile data will be removed from your computer.

After uninstalling Firefox on Windows, delete the "Mozilla Firefox" program folder, located by default in one of these locations:

  • (On 32-bit Windows) C:\Program Files\Mozilla Firefox
  • (On 64-bit Windows) C:\Program Files (x86)\Mozilla Firefox
  1. Go to the Windows Start menu and click on "Computer".
  2. In the Explorer window that opens, double click Local Disk (C:) to open the C:\ drive.
  3. Find the "Program Files (x86)" folder or "Program Files" folder.
    • On 32-bit Windows, double-click the Program Files folder to open it.
    • On 64-bit Windows, you will see a "Program Files (x86)" folder AND a "Program Files" folder. Open the Program Files (x86) folder.
  4. Look for a Mozilla Firefox folder. If you find one, right-click it and select Delete and confirm that you want to move the folder to the Recycle Bin.

Now, go ahead and reinstall Firefox:

  1. Double-click the downloaded installation file and go through the steps of the installation wizard.
  2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!


thanks

Question owner

Smooth scrolling enabled or disabled, no change. Hide pointer while typing unchecked, no change. Closed FF and uninstalled it. Deleted the program folder. Did reboot for XP. Installed FF again (had already 18.0.2 file after previous update). No help for bad behaviour of the cursor. It is sticking only in active FF window, not anywhere else.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

If, as you said, in firefox safe mode, it is OK., and you check, extensions + hardware acceleration, you switch also to default toolbar layout, and the problem is not there, then try to disable (JIT) JavaScript compiler and check it again :

in about:config :

  • javascript.options.jit_hardening
  • javascript.options.methodjit.chrome
  • javascript.options.methodjit.content

make all the above FALSE (double-click on every one), exit firefox and restart it.

[in safe mode (JIT) JavaScript compiler is disable], but i can not understand how may jit related with that !


thanks

Question owner

Made all the above "false" but could not make the setting stay. When restarted FF, they were changed to "true" again.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

should remain as you set it, see Corrupt or damaged prefs.js file

see also, if you can Lock the preferences


thanks

Question owner

OK, now i got the settings changed. Did not help in the cursor problem however.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

I love how when everyone has the issue it has to be us or an extension. This started for everyone on FF 18 so logic dictates it's FF 18.

The problem does NOT affect everyone, or even everyone on Windows XP.

So even if the problem only arises on Fx18 the important differences could quite possibly be changes made by those with the problem: customisations, changed preferences but most likely of all different extensions.

Modified by John99

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

is the problem still there on firefox 19 & are you using a setup with multiple monitors?

Modified by philipp

Question owner

Hello again, just updated to FF 19 today. See no improvements to this cursor problem, it seems to be here for stay. Platform is Asus eeepc, no multiple monitors.