X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 18.0 got a new feature: cursor jumping from link to link, how to disable this?

Posted

windows xp sp3 Cursor is no more following smoothly with mouse movement, it stops and jumps all the time. Feel this annoying and would like to disable the feature but it cannot be found nowhere in tools-options. It just came with update to version 18.0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.35
true
{CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}
Key config
0.3.1
true
keyconfig@petricek.net
Java Quick Starter
1.0
false
jqs@sun.com
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
10240
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
983040
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.startup.homepage_override.buildID
20130104151925
browser.startup.homepage_override.mstone
18.0
browser.tabs.loadInBackground
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
18.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358012054
places.history.expiration.transient_current_max_pages
26578
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Graphics Media Accelerator 500
Adapter Drivers
igxprd32
Adapter RAM
Unknown
Device ID
0x8108
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (0.0.0.0)
Driver Date
4-28-2009
Driver Version
6.14.11.1009
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 9
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 500)
Vendor ID
0x8086
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

ideato
  • Top 25 Contributor
618 solutions 4263 answers

Hello jorma, try to Turn off hardware acceleration, and check it again.

thank you

Question owner

Thank you for your fast reply. I alreade tried to uncheck the hw acceleration, unfortunately that did not help. Cursor still having bad behaviour in Firefox window. And only there.

ideato
  • Top 25 Contributor
618 solutions 4263 answers

Check it in Safe Mode, in Safe Mode window select "Start in Safe Mode" and see if this happen again, if not then see: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

(If the problem does not happen in Safe Mode, it is most likely because of an extension, theme or hardware acceleration, hardware acceleration not in your issue, like you said).


thanks again

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Helpful Reply

You may have switched on caret browsing.

You can press press F7 (on Mac: fn + F7) to toggle caret browsing on/off.

  • Tools > Options > Advanced : General: Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Question owner

It was not "caret browsing" either. Tried to check-uncheck with no change in cursor behaviour. Safe mode corrected this finally. So I went back to normal mode and tried to drop off add-ons one by one. It was none of them. It has to be some setting in Firefox itself but how to find it? Or do i need to reset the software?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Try to disable hardware acceleration in Firefox.

Question owner

Please read from the beginning, disabling hw acceleration was the first suggestion.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.

Question owner

It wasnt that either. There was 400, i changed it to 1000 but that didnt help. Actually, the problem is not in scrolling, its in mouse movent across a web page. The cursor is "sticking" in links and jumping from link to link. There is no problem with web pages not containing links.

Modified by jorma

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Are you sure that it isn't a problem with caret browsing?

What you describe sounds just like it.

Question owner

Checked or unchecked "Always use the cursor keys to navigate within pages" does not change the bad behaviour of cursor.

Question owner

I did a software reset (help>restart..) and it did not help.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

gnunesjr 0 solutions 1 answers

Helpful Reply

I have the same problem, and I would like to add some details.

I have a two screen system. When I start Firefox 18, my cursor no longer moves smoothly around the screen, as long as the Firefox window is active. So, again: I have Outlook open on my left screen, and Firefox open on my right. If I click on Outlook to make that program active, my mouse cursor moves smoothly over both screens.

If I click on Firefox to make it active, my cursor moves with a maddening, annoying jerky motion with random pauses that are not associated with being over a link, even when it is over on the left screen showing Outlook. I do however, feel that is related to links, because if I move the mouse over an area with links, the motion is really jerky, and I can see the mouse hanging up on the links.

I would like this behavior to go away. All the way away. I don't want jerky mouse movement, either on a link or not on a link.

If this is a "feature", it needs to be one that can be turned off.

Modified by gnunesjr

Question owner

What more can i get with windows safe mode? Firefox safe mode is enough to stop this problem but it did not help me to find the root cause. And i do not want to start Firefox in safe mode everytime.

Modified by jorma

ideato
  • Top 25 Contributor
618 solutions 4263 answers

If the problem does not happen in Safe Mode, it is most likely because of an extension, theme or hardware acceleration, (hardware acceleration not in your issue, like you said already) try to Disable all extensions and then if the problem no longer occurs with all extensions disabled, one of your extensions was causing it, then re-enable each extension one at a time to see the faulty one.

thanks again

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Try to disable hardware acceleration in Firefox.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Question owner

Intel Atom Z520, Intel GMA500, XP sp3, Firefox 18.0, only default theme installed - Once again: Tried to disable hw acceleration and all extensions & plugins, no change. Only Firefox safe mode helps. Got enough. Now im going to use Opera as long as new update is released for Firefox.

Modified by jorma

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

acsmith1972 0 solutions 15 answers

I love how when everyone has the issue it has to be us or an extension. This started for everyone on FF 18 so logic dictates it's FF 18. I'm going to try to roll back if I can ... sorry, it just jumped...I'm going to try to find a previous version or just switch to Chrome. I'm tired of this b.s.