X
Tap here to go to the mobile version of the site.

Support Forum

Firefox process does not stop. Reset Firefox and Restart with Add ons disabbled is also not working.

Posted

I always need to stop firefox in the task manager. Resetting and restarting without add ons is not possible because Firefox hangs on shut down.

I always need to stop firefox in the task manager. Resetting and restarting without add ons is not possible because Firefox hangs on shut down.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Shockwave Flash 11.5 r502
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • 5.1.10411.0
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

since Firefox 18.0

philipp
  • Top 10 Contributor
  • Moderator
2974 solutions 13817 answers

hello ldelde, you can also access safe mode by pressing the shift-key while firefox is launching - then a dialog with the option to reset firefox should show up (see screenshot). please try if you can resolve the issue this way...

hello ldelde, you can also access safe mode by pressing the shift-key while firefox is launching - then a dialog with the option to reset firefox should show up (see screenshot). please try if you can resolve the issue this way...

Question owner

Thanks, good tip, but not solving my issue. As long as only start firefox in safe mode I can restart and restart. If I start 1 time firefox in normal mode, next time I get the error message. All my addons are disabled.

Thanks, good tip, but not solving my issue. As long as only start firefox in safe mode I can restart and restart. If I start 1 time firefox in normal mode, next time I get the error message. All my addons are disabled.
cor-el
  • Top 10 Contributor
  • Moderator
12316 solutions 114011 answers

Try to disable hardware acceleration in Firefox.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled *the default theme is used (no persona) *userChrome.css and userContent.css are ignored *the default toolbar layout is used *the Javascript JIT compiler is disabled *hardware acceleration is disabled *plugins are not affected *preferences are not affected

Question owner

Disabling hardware acceleration is NOT solving the issue. Looks this is a new problem since version 18.0.

Disabling hardware acceleration is NOT solving the issue. Looks this is a new problem since version 18.0.
zoltanbarco 0 solutions 2 answers

Since Firefox 18, I have exactly the same problem as you described. None of the proposed solutions work for me. Beta version 19.0b3 has the same issue. My system is Windows7-x64, and my Firefox has the usual plugins and extensions (Acrobat, Java, MS Office, Flash, ... in their latest update). Disabling the Extensions/plugins does not help.Finally I reverted back to Firefox 15.0.1 using exactly the same plugins/extensions. And here everything works fine. Of course I blocked the Firebox update now.

Since Firefox 18, I have exactly the same problem as you described. None of the proposed solutions work for me. Beta version 19.0b3 has the same issue. My system is Windows7-x64, and my Firefox has the usual plugins and extensions (Acrobat, Java, MS Office, Flash, ... in their latest update). Disabling the Extensions/plugins does not help.Finally I reverted back to Firefox 15.0.1 using exactly the same plugins/extensions. And here everything works fine. Of course I blocked the Firebox update now.
amarach78 0 solutions 3 answers

I also have the same problem and configuration as zoltanbarco. Somehow the firefox process hangs and if you do a restart from within firefox this is not working since the process is not first stopping/exiting or whatever should happen before the restart/restore/... can happen.

I also have the same problem and configuration as zoltanbarco. Somehow the firefox process hangs and if you do a restart from within firefox this is not working since the process is not first stopping/exiting or whatever should happen before the restart/restore/... can happen.
cor-el
  • Top 10 Contributor
  • Moderator
12316 solutions 114011 answers

Helpful Reply

Did you try Firefox Safe mode?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

If it works in Windows Safe mode then you have a problem with other software, likely security software or a system driver, that is running on your computer.
Make sure that you have the latest updates of your security software.

You can use the Autoruns utility to see which software and services gets started.


See also:

Did you try Firefox Safe mode? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. If it works in Windows Safe mode then you have a problem with other software, likely security software or a system driver, that is running on your computer.<br /> Make sure that you have the latest updates of your security software. You can use the Autoruns utility to see which software and services gets started. *http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx ----- See also: *"Hang at exit": http://kb.mozillazine.org/Firefox_hangs *"Firefox hangs when you quit it": https://support.mozilla.org/kb/Firefox+hangs
amarach78 0 solutions 3 answers

Thanks for trying to help Yes I tried safe mode both of firefox and of windows but that did not help I cannot disable my extensions since it needs a clean restart of firefox but that is not possible due to the fact that the process hangs. I tried reinstalling firefox but no help

Thanks for trying to help Yes I tried safe mode both of firefox and of windows but that did not help I cannot disable my extensions since it needs a clean restart of firefox but that is not possible due to the fact that the process hangs. I tried reinstalling firefox but no help
pcmaan 0 solutions 3 answers

Helpful Reply

Hi, I was experiencing the same problem since a couple of weeks. I am on Firefox 18, WinXP SP3.

The way I got rid of it was by removing a file called secmod.db in my firefox profile directory. Firefox recreated the file and the problem is gone.

By default the profile directory on WinXP is C:\Documents and Settings\your_username\Local Settings\Application Data\Mozilla\Firefox\something.default

I guess on Windows Vista and up, the folder is somewhere below c:\users. Doing a search for .default might help you find it. I think it is a hidden/system folder though, so you might want to turn their visibility on.

Hope that helps

Hi, I was experiencing the same problem since a couple of weeks. I am on Firefox 18, WinXP SP3. The way I got rid of it was by '''removing a file called secmod.db ''' in my firefox profile directory. Firefox recreated the file and the problem is gone. By default the profile directory on WinXP is C:\Documents and Settings\your_username\Local Settings\Application Data\Mozilla\Firefox\something.default I guess on Windows Vista and up, the folder is somewhere below c:\users. Doing a search for .default might help you find it. I think it is a hidden/system folder though, so you might want to turn their visibility on. Hope that helps

Modified by pcmaan

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1226 solutions 8030 answers

Restart your computer, then when you open up Firefox, hold down the shirt key. Click the "Reset Firefox" button there, does that work? This is probably being caused by an add-on.

Restart your computer, then when you open up Firefox, hold down the shirt key. Click the "Reset Firefox" button there, does that work? This is probably being caused by an add-on.
pcmaan 0 solutions 3 answers

This suggestion was given before, (2nd post) but not solving the problem.

This suggestion was given before, (2nd post) but not solving the problem.
cor-el
  • Top 10 Contributor
  • Moderator
12316 solutions 114011 answers

Did you check for problems caused by plugins?

Did you check for problems caused by plugins? *https://support.mozilla.org/kb/Troubleshooting+plugins
amarach78 0 solutions 3 answers

removing (actually I renamed it) the file called secmod.db suggested by pcmaan solved the problem for me. I do not yet know the impact of this change but I can always go back with the backup. Thanks pcmaan!

removing (actually I renamed it) the file called secmod.db suggested by pcmaan solved the problem for me. I do not yet know the impact of this change but I can always go back with the backup. Thanks pcmaan!
pcmaan 0 solutions 3 answers

I tried deleting pluginreg.dat, didn't help. Deletion of secmod.db fixed it.

What is secmod.db for ?

I tried deleting pluginreg.dat, didn't help. Deletion of secmod.db fixed it. What is secmod.db for ?
zoltanbarco 0 solutions 2 answers

Thanks pcmaan, the deletion of secmod.db solved the problem for me. I also have to mention that I first had the problem with v18.0.1, and now I have v18.0.2. For more information on secmod.db, see here

Thanks pcmaan, the deletion of secmod.db solved the problem for me. I also have to mention that I first had the problem with v18.0.1, and now I have v18.0.2. For more information on secmod.db, see [http://www.mozilla.org/projects/security/pki/nss/tools/modutil.html here]