X
Tap here to go to the mobile version of the site.

Support Forum

Keyboard unresponsive when opening firefox.

Posted

Sometimes when I turn on my laptop, my keyboard will not work in firefox but works in every other application... Not even one key will work. I have to restart my computer to get it to work again... and lately it has happened every single time I have opened firefox... I am unsure what to do. Any help would be appreciated.

It irritates me I have to use internet explorer... terrible browser.

Sometimes when I turn on my laptop, my keyboard will not work in firefox but works in every other application... Not even one key will work. I have to restart my computer to get it to work again... and lately it has happened every single time I have opened firefox... I am unsure what to do. Any help would be appreciated. It irritates me I have to use internet explorer... terrible browser.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; .NET4.0E)

More Information

Andrew
  • Moderator
275 solutions 3564 answers

Hello ashkeemash,

Thank you for posting on Mozilla Support. We value and appreciate as a user.

Please try a "Reset" as outlined below;

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank You!


Did you know that Mozilla Support is helped out by volunteers? Be part of SUMO! http://mzl.la/OJtpch

Donate more than $30 and get a T-Shirt! https://donate.mozilla.org/page/contribute/joinmozilla

Hello ashkeemash, Thank you for posting on Mozilla Support. We value and appreciate as a user. Please try a "Reset" as outlined below; The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank You! ---- Did you know that Mozilla Support is helped out by volunteers? Be part of SUMO! http://mzl.la/OJtpch Donate more than $30 and get a T-Shirt! https://donate.mozilla.org/page/contribute/joinmozilla

Question owner

I have done that multiple times and it still continues to happen every day.

I even reimaged my computer on tuesday hoping something would make it better, but firefox still refuses to let me use my keyboard!

Besides, resetting or uninstalling/reinstalling every day gets to be annoying.

I have done that multiple times and it still continues to happen every day. I even reimaged my computer on tuesday hoping something would make it better, but firefox still refuses to let me use my keyboard! Besides, resetting or uninstalling/reinstalling every day gets to be annoying.
cor-el
  • Top 10 Contributor
  • Moderator
12017 solutions 111660 answers

Do you have multiple keyboard layouts installed?

It is possible that you have switched the keyboard layout by accident.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that Firefox uses for some menu items
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)

Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Do you have multiple keyboard layouts installed? It is possible that you have switched the keyboard layout by accident. * http://support.microsoft.com/kb/258824 - How to change your keyboard layout Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut. * http://windows.microsoft.com/en-US/windows-vista/The-Language-bar-overview - The Language bar (overview) * Make sure that you have the Language bar visible on the Windows Taskbar * You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar * Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar * You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application * The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that Firefox uses for some menu items * To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift) Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Question owner

I have no idea what you are talking about... so no??

I have never changed any keyboard settings in firefox at all.. it just simply no longer works in firefox....

i just uninstalled and reinstalled firefox for the 9th time this week... keyboard does not work at all in it.

I have no idea what you are talking about... so no?? I have never changed any keyboard settings in firefox at all.. it just simply no longer works in firefox.... i just uninstalled and reinstalled firefox for the 9th time this week... keyboard does not work at all in it.
balyoa 0 solutions 1 answers

Hello,

I have the problem too, on WIndows XP sp3. Firefox works well only if i reinstall the version 16 (french). Since the version 17, keyboard doen't respond....

All others sofwtares (IE et chrome) work perfectly ;-(

Thanks

Hello, I have the problem too, on WIndows XP sp3. Firefox works well only if i reinstall the version 16 (french). Since the version 17, keyboard doen't respond.... All others sofwtares (IE et chrome) work perfectly ;-( Thanks