X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox very slow and hogs resources when displayed on 1 monitor of 2 monitor set up, runs normally when displayed on the second monitor.

Posted

Firefox has worked perfectly well for some time on this machine (Dual core AMD Athlon with XP SP3). This morning at startup Firefox opened on my second (DVI) monitor, not on its usual VGA connected screen. I used the maximise button to shrink the window from full screen and dragged it to the correct monitor and remaximised it. It then was very slow, mouse movements happened in large increments making it difficult to point and click, switching tabs resulted in a slow vertical wipe to reveal content rather than instantaneous switching, loading websites was very slow indeed. Using task manager indicated that one CPU core was running at or near max much of the time, particularly when moving the mouse. I rebooted and also reset Firefox to no avail. However, if I move the Firefox window from the VGA monitor to the DVI one then performance/resource usage is normal. I can open other apps on the VGA monitor (eg MS Word) and they behave normally. It just seems to be Firefox that is having this problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • 5.1.10411.0
  • GEPlugin
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{
"application": {
"name": "Firefox",
"version": "18.0",
"userAgent": "Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0/WINNT/en-US/"
},
"modifiedPreferences": {
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage": "https://www.google.com/calendar/render?tab=wc|http://www.rsgbcc.org/vhf/|http://www.on4kst.com/chat/start.php?callsign=G3XDY&password=dfa867d23a9b66ebbf442c48b93d1900|https://www.google.co.uk/",
"browser.startup.homepage_override.buildID": "20130104151925",
"browser.startup.homepage_override.mstone": "18.0",
"extensions.lastAppVersion": "18.0",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 53667,
"places.database.lastMaintenance": 1357916506,
"privacy.sanitize.migrateFx3Prefs": true
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 1,
"windowLayerManagerType": "Direct3D 9",
"adapterDescription": "ATI Radeon HD 2400 PRO ",
"adapterVendorID": "0x1002",
"adapterDeviceID": "0x94c3",
"adapterRAM": "Unknown",
"adapterDrivers": "ati2dvag",
"driverVersion": "8.712.0.0",
"driverDate": "3-2-2010",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": false,
"directWriteEnabled": false,
"directWriteVersion": "0.0.0.0",
"direct2DEnabledMessage": [
"tryNewerDriver",
"10.6"
],
"webglRenderer": "Google Inc. -- ANGLE (ATI Radeon HD 2400 PRO )",
"info": {
"AzureCanvasBackend": "cairo",
"AzureFallbackCanvasBackend": "none",
"AzureContentBackend": "none"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
}
},
"extensions": [
{
"name": "avast! WebRep",
"version": "7.0.1474",
"isActive": false,
"id": "wrc@avast.com"
},
{
"name": "Google Gears",
"version": "0.5.36.0",
"isActive": false,
"id": "{000a9d1c-beef-4f90-9363-039d445309b8}"
},
{
"name": "Java Console",
"version": "6.0.37",
"isActive": false,
"id": "{CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}"
},
{
"name": "Java Quick Starter",
"version": "1.0",
"isActive": false,
"id": "jqs@sun.com"
},
{
"name": "Microsoft .NET Framework Assistant",
"version": "0.0.0",
"isActive": false,
"id": "{20a82645-c095-46ed-80e3-08825760534b}"
},
{
"name": "RealDownloader",
"version": "1.3.0",
"isActive": false,
"id": "{34712C68-7391-4c47-94F3-8F88D49AD632}"
}
]
}

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello ham3400, please try updating your graphics driver, this should be the right link for your model: http://support.amd.com/us/gpudownload/windows/legacy/Pages/legacy-radeonaiw-xp.aspx

or disable hardware acceleration in firefox > options > advanced > general...

Question owner

Hi Madperson

Thanks for the link, I have loaded the new drivers and that made no difference, and turning off hardware acceleration also has no effect. To give some idea of the performance hit the mouse cursor update rate is about once per second, and character repeat when editing is about 1 character per second.

PS I had the monitor identities the wrong way round - the problem occurs when Firefox is displayed on the DVI monitor, and its OK on the VGA one.

Other suggestions welcome! Ham3400

Modified by ham3400

engineeral 0 solutions 1 answers

Same problem with two monitors. It affects only the one monitor whether it is the primary or secondary monitor. Worked fine until FF18. XP Pro SP3, Athlon Dual Core 4450B 4 GB ram on-board ATI Radeon 3100

Question owner

The problem has morphed here, in that I now have acceptable performance under most circumstances (without having changed anything to my knowledge), except when the bookmarks list is opened, and mouse movement becomes erratic again. Following a tip found elsewhere I tried changing from the default Firefox theme (I chose Gallant Silver), now the main bookmarks list is faster but the bookmarks in folders at the second level are still unacceptably slow. The Tools/Options window is also slow when opened.

AndyB828 0 solutions 1 answers

I have the original problem. Firefox works great when all of its windows are open on my laptop's LCD screen. (It's a Lenovo T420s.) When I move a FF18 window even partially onto the second monitor, and then move the mouse within the window, CPU utilization spikes. The mouse tracking is "sticky" when the pointer passes over menu elements and links that have visual mouse-over effects; that is, the pointer stops while the button or menu appears and then jumps to where it should be. The overall effect is so annoying that I have to keep all my FF windows on the primary (integrated) display. This first appeared in FF18 and continues in FF18.0.2.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

i've filed bug#841752 for this issue.

Question owner

Thanks Madperson, still having problems with slow bookmarks here so would like to see some work on this problem from the development team.

ham3400

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

slow bookmarks should be sorted with firefox 19 which is going to be released next week - you could also test the beta version right now: http://www.mozilla.org/firefox/channel/

CWTL 0 solutions 2 answers

I'm having the same exact problem as described here. Running XP 32 bit SP3, Intel D945GNT w/on board video plus NVIDIA GeForce 8400 GS display adapter; Intel P4 3.00 ghz processor. The problem does not occur on the GeForce card, only with the on-board monitor and it appears not to occur when FF is in safe mode. It's not only using up CPU resources, but is exhausting my time and patience as well. I'm ecstatic just to have found this page/forum. Help!

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

does disabling hardware acceleration as explained in the first post make a difference for you when you run firefox normally (not in safemode)?

CWTL 0 solutions 2 answers

Initial test is affirmative - it seems to resolve the problem. I'm embarrassed that I didn't read that solution all the way through and give it a try before posting the issue here. I did install the 19.0 Beta version of Firefox, so at least it appears to resolve the issue in that context and I'll keep an eye on it. Will disabling the hardware acceleration have any other adverse side effects? Thanks very much for your expertise and the prompt response. I'm very appreciative.

Question owner

The problem has recurred here. I started up the machine a couple of days ago and found that Firefox opened on the "wrong" monitor. Having moved the Firefox window to the DVI monitor, screen scrolling updates are about once per second and videos play at about 1 frame per second. I updated to V21 - just the same behaviour, and turning off hardware acceleration has no effect.

Has the bug previously reported been fixed?

Question owner

Today its all OK again - very strange, no changes that I'm aware of since last report. Does Firefox do silent updates?