X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Fonts not displaying or printing correctly in Firefox 18

Posted

I upgraded to Firefox 18 on my MacBook Pro a couple of days ago. Ever since, the fonts, both on display and in print, look rather bad.

-- Anything in bold is blurry on display, and almost impossible to read when printed. -- All fonts appear smaller, even though my default font size and minimum font size have not changed. -- I'm using Times for my serif font, but its use seems inconsistent from site to site. The only time font use is consistent is when I switch to Helvetica and/or change the proportional font to sans serif.

I typically leave "Allow pages to use their own fonts" off, because I prefer to read everything in serif. The issue, however, is there whether I leave that setting on or off.

I'm using OS 10.6.8 and Suitcase Fusion 3 to manage fonts.

Any suggestions?

Modified by dmherm

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • 5.1.10411.0
  • Plug-in for Starfield utilities
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

Try to disable hardware acceleration in Firefox.

You can also do a check for corrupted and duplicate fonts and other font issues:

Helpful Reply

None of that worked -- tried resetting zoom, and turned hardware acceleration off, with no effect. The fonts were working fine in previous versions of Firefox, and are working just fine with Safari and Chrome. I also checked them with Font Doctor and Suitcase, and they were fine.

Note that this problem appears on screen with all serif fonts that are active (not just Times), and all fonts when printing.

Any other ideas?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Did you check which fonts Firefox is using in those cases?

TheRogueSkolar 0 solutions 3 answers

Unusable!

I had a very similar problem albeit on a different platform. I was using FFox 18 on Ubuntu 12.10. I noticed fonts we're blurry/fuzzy at small sizes and some fonts were fuzzy when bold irrespective of size. And before someone points it out, no this for the most part wasn't an issue of missing font weights. I tested this several font families (ubuntu to name one) that have a fairly complete set of weights and styles. Funnily when I hit CTRL+ the issue with smaller font sizes was resolved.

In the end I just reverted back to FFox 17 and I'll keep using it until they fix this issue or just wait for the next release.

Modified by TheRogueSkolar

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

For anyone who is seeing this issue, can you give a screenshot of the problem? Also, can you give a comparison of another browser that is correct? How do I create a screenshot of my problem?

Triptoph 0 solutions 2 answers

Same problem here. Have already tried resetting view to default (was already at the default zoom) and I already have hardware acceleration turned off. FF 18.0 on OS X 10.8.2. Screenshots are attached clearly showing the difference, using Chrome for comparison. Both are from the default dashboard of astrid.com

dholmes 0 solutions 1 answers

Pictures attached. Same google doc in Firefox 18.0.1 and Chrome 26.0.1384.2. Viewing at actual size, the Firefox document text (but no other text) is much fuzzier than the Chrome version.

Oops - missed the above when I submitted this. Sorry for duplicate info.

Modified by dholmes

bethc 0 solutions 1 answers

Glad to hear I'm not alone. I have 18.0.1. My wordpress site looks like hash marks. It's awful. Not a problem in Explorer. Not a problem on other sites. But I don't want others viewing my site I am!

Juan Báez Rojas 0 solutions 4 answers

Helpful Reply

I'm not a Mac user but I've tweak some preferences under my Linux box and now everything looks normal

More help there [Since Upgrade to Firefox 18, Fonts Look Blurry when Loading Pages]

TLDR

Go to about:config page and tweak this preferences

layers.acceleration.force-enabled > true

layers.acceleration.disabled > false

gfx.xrender.enabled >false

Modified by cor-el

Triptoph 0 solutions 2 answers

No help there. But from the thread you linked, it sounds like this may be solved in FF19 so I'll just put up with it till it is released.

Juan Báez Rojas 0 solutions 4 answers

I suggest you to download the Firefox 17 ESR version, that versión will not try to update itself to Firefox 18 since it is designed for organizations that are afraid of the mozilla rapid release cycle

Firefox Extended Support Release

TheRogueSkolar 0 solutions 3 answers

Good suggestion @juanbaez

Unfortunately didn't work for me. What distro you are you running? I'm on a 'Buntu (Qantal) box.

There's a screengrab of what I'm getting below.

Look at the "Gmail" and "inbox" text. Granted this is only a small sample but when you've got a full page of text the blurry font rendering on FF18 can give you a headache. This seems to be happening on default zoom/scale.

A couple of things I've noticed:

  • Hitting CTRL+ seems to resolve the issue
  • Adding a background color to the element containing the text also seems to resolve the issue.

D@mn now I need to uninstall FF18 and reinstall 17.

Modified by TheRogueSkolar

Juan Báez Rojas 0 solutions 4 answers

Im running Ubuntu Gnome Remix 12.10 on Gnome Fallback Mode + compiz

Try with this pref:.

gfx.work-around-driver-bugs > false

TheRogueSkolar 0 solutions 3 answers

Amazing.

This seems to have resolved the issue. I'll have to do more testing but so far it's looking good.

Big Props guy!