X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes when going on Facebook.

Posted

I use Firefox on a Mac (Snow Leopard) and I recently updated Firefox to version 18.0. After I updated, Firefox will freeze everytime I go on Facebook and I would have to force quit it. One thing I noticed is that it crashes when almost everything is loaded but the chat. Does anyone know how to fix this?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

oldbrad 0 solutions 2 answers

The problem appears to have returned with 19.0 !

oldbrad 0 solutions 2 answers

This problem is becoming very serious! A web search indicates that the problem, probably related to the flash plugin, is wide spread, unpredictable and extremely difficult to eliminate.

I can confirm that it's not just Facebook, almost any site attempting to deliver embedded flash (.swf) is potentially capable of crashing Firefox.

The problem, according to some, is related to attempts by the flash player to use hardware acceleration. For anybody who knows anything about graphics hardware driving this explains everything. There are perhaps hundreds of combinations of different versions of graphics cards and drivers, maybe even thousands! There are indication that some FF crashes are silent. ie the crash report is empty and FF recovers and continues. Who knows? I certainly see both the "We are sorry" message and FF just silently disappearing. I'm currently monitoring about:crashes after ever session.

The SERIOUS problem is that following such graphics crashs almost anything can happen. Because the DMA, or whatever is going wrong at the hardware level can, and probably will, write crap all over the operating system!

I'm running FF 19.0 on a fully updated Fedora 17 system and I'm, AGAIN, seeing file system CORRUPTION of the .mozilla/firefox/Crash Reports and .../minidumps directories. The corruptions are not evident until a following reboot when automatic runs of fsck detect the corruption. On the crash m/c my wife is banned from going to Facebook altogether. She does, however, visit the BBC Iplayer, Webmail and of course Google. Almost all but most trivial site will be delivering flash these days!

The crash is bad enough, but file system corruption is wholly UNACCEPTABLE. So my question is this:

How do I disable Firefox crash dumps?

Apart from removing FF altogether that is!

Question owner

Yeah. Once I use too much flash on Firefox it starts to lag a lot.

nancybhenry 0 solutions 3 answers

I had this problem too. I had tried EVERYTHING!

This finally fixed the problem.

1. Close Firefox completely

2. Click on Start | Run | Type “firefox.exe –p” without quotes

3. Click OK

4. Click on Create Profile | Choose the user Profile Window.

5. In Create Profile Wizard click on Next.

6. Type the name in New Profile Name and Click on Finish.

7. Uncheck Don’t ask at Startup and click on Start Firefox.


This newly created user profile would appear whenever you start Firefox web browser. If you do not want to see this Window quite often, uncheck this Window.


Read more: http://digitaljournal.com/blog/15416#ixzz2Mmamk3hJ

BigSky1970 0 solutions 1 answers

It's FF 18. I downgraded back to 16.0.1 and haven't had problems. Using Mac OS X 10.8.3.

StevenCee 0 solutions 50 answers

I'm using FF 21, and all use of FB is slow, slow, slow, spinning wheels, CPU usage up above 100%, etc, etc..... This is so very frustrating. A billion people + use Facebook, if a modern browser can't deal with that, something's wrong....