Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

  • 25 replies
  • 13 have this problem
  • 968 views
  • Last reply by kamastudio

more options

I am a regular user of the Kunena-based forum at lwks.com. Kunena is a Joomla extension. I have been using this forum using Firefox for the past two years without problem. After updating to FF18.0 yesterday, I now find that I cannot insert images or other files into forum posts. When I click on the Add File button and select a file (e.g. jpg) the path to the file on my desktop no longer appears in the Add file box and the Insert button is missing so I am unable to insert the file as an attachment to the forum post.

Chosen solution

Try changing the following 2 files:

in /components/com_kunena/template/default/js/editor.js

var input = __file.getElement('input.kfile-input')

to

var input = __file.getElement('input.kfile-input.hidden')


in /components/com_kunena/template/default/js/editor-min.js

var a=c.getElement("input.kfile-input").set

to

var a=c.getElement("input.kfile-input.hidden").set

Read this answer in context 👍 3

All Replies (20)

more options

It was an issue with Mootools library not FF18

Mootools function getElement( "input.kfile-input" ) was finding

<input class="kfile-input-textbox"> instead of <input class="kfile-input hidden">

fixed by using getElement( "input.kfile-input.hidden " ) instead

Thanks for reporting.

Modified by WooDzu

more options

Many thanks for your reply.

more options

having the same problem using joomla 1.5 with kunena however we have a test site using joomla 2.5 and that works ok. Still have this issue

more options

Chosen Solution

Try changing the following 2 files:

in /components/com_kunena/template/default/js/editor.js

var input = __file.getElement('input.kfile-input')

to

var input = __file.getElement('input.kfile-input.hidden')


in /components/com_kunena/template/default/js/editor-min.js

var a=c.getElement("input.kfile-input").set

to

var a=c.getElement("input.kfile-input.hidden").set

more options

Many thanks fro the response.

SOLVED

more options

Thanks WooDzu alas it did not work on our site.

more options

What version is your site running?

Our is MooTools 1.2.5 (from MooTools Upgrade plugin), a minified and compressed version.

more options

Same version

more options

I could take a quick look if you share your site's URL

Modified by WooDzu

more options

you will need a user name

user: test password: forum

more options

Thanks. Well, I can see the same issue on your site.

Replaced your editor-min.js with the one from www.lwks.com and it works fine for me on FF18. The only issue that I can think of is that when you edited the file it added some unnecessary backslashes to it, which now causes syntax errors see Firebug/Chrome inspector.

To fix it you can try replacing you js with the one from lwks.com or even better reverse your changes and use a different editor to apply the above solution.

more options

ok will have a go with a different editor, many thanks

more options

replaced both file with backups and modified using another editor, no more lines but still not working.

When i checked with fire bug got this line

<input type="file" name="kattachment" class="kfile-input hidden" id="kupload">

the . between input and hidden is missing although it is in both files, i am not sure where this code is but putting a . in with firebug shows up the browse button.

Any help would be appreciated again

more options

I see the forum attachments are working back again

more options

Still not getting them here, all we are getting is add file but when you press it it invites you to add an image you select one press open and nothing appears, before you had an extra set of commands like add and insert but nothing now. Its the code i see using firebug, the . appears to be missing but this gives a browse button which we never had before

more options

Perhaps the editor-min.js file got cashed by your browser. Try clearing the cache or use Firebug to switch it off temporarily

Double checked now, and it looks fine from here

Modified by WooDzu

more options

you were correct again, been clearing it all day, not that time, yes it has come back to life. found out some interesting stuff today, do not use ACE FTP to edit files a sit seems to add lots of /////////////////////

and keep clearing cache. Many thanks for your patience and help WooDzu

more options

Glad to hear it's fixed.

more options

http://www.starvmax.com

the ADD FILE button works with Firefox v17esr or older but NOT with v18.0 or newer...

  1. 1
  2. 2