X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My browser opens to whatever website I last visited, even though I have my settings set to open to my homepage

Posted

I go to options, set it up to open to my homepage, and it still opens to whatever page I visited last. I tried clearing my cache as well, no luck. What can I do to make my browser open to my homepage every time?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NDS Player Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • 5.1.10411.0
  • NPWLPG
  • Provides additional functionality on Facebook. See our web site for details.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Black Thunder 0 solutions 9 answers

Hello,

Did you change the When Firefox Starts option?

Question owner

Yes. I actually never changed the When Firefox Starts option--one day it just started opening to whatever page I closed it on. I looked at the When Firefox Starts option and it was still set to my homepage, yet it always opens to the last page I was on before I closed the browser.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the task manager as this may cause Firefox to think that the session crashed and thus needs to be restored.

Use "Firefox/File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") to close Firefox if you are currently doing that by clicking the close X on the title bar.

See also:

Question owner

I usually just hit the x in the upper right-hand corner to close out of the browser, this time I did it through the Firefox file menu as you suggested and had the same result. Looked at the other links you posted under your answer and neither link was appropriate. Any other suggestions?

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

In case you are using "Clear history when Firefox closes":

  • do not clear the "Browsing History"

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Question owner

I appreciate you taking the time to offer suggestions, but I still don't have an answer. I don't get it.

Jenz5 0 solutions 1 answers

I am also having this problem, no matter what i do Firefox still opens to the last page me or my kids were on when we closed it. I have tried to "exit" and I have tried the X it doesn't matter. I have checked my settings as suggested..they are all fine. If anyone has anymore i would be glad to hear them,. Original Poster, have you fixed yours? If so I would love to hear from you.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Question owner

How do I find the Firefox profile folder?

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Question owner

The only "user" file in that folder simply says "user" and does not have a .js extension.

vanderbilt 0 solutions 1 answers

Helpful Reply

Go to <HELP> <Troubleshooting Information> Click on <Reset Firefox> That fixes the problem!

All cookies and bookmarks will remain; however, some Add-ons or extensions may have to be enabled or reinstalled.

Then go to <Tools> Option> <General> and put your homepage in. Go through each tab and make any desired changes to your preferences.

Modified by vanderbilt

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension.

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

andy2013 0 solutions 1 answers

Hi,

Same problem in the past few days, being able to restore is not the problem, everytime I open I do not go to the simple home page it appears to restore to the last site visited.

I usually click the X in the corner but have tried using File > exit as suggested and the problem remains.

Going to restore the last session effectively means I don't have a home page unless I click back to it for the new session, could also be be messing with the last site owners statistics / bandwidth.

Going to the the pages suggested mean very little to me as like most users I don't understand how the program is built.

I don't mind a small bug but am very concerned about possible virus or similar nasties.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Hi andy2013

You can try to reset Firefox if you aren't able to try the above posted suggestions.

If you reset Firefox then a new profile is created and some of your data (bookmarks,history, cookies, passwords, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data).

It is possible to recover more data from the old profile, but be cautious to avoid carrying over the problem.