Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 18 crashes

  • 34 replies
  • 89 have this problem
  • 7218 views
  • Last reply by oneofj

more options

I love Firefox. On my laptop ( ASUS UX32VD-DB71 ) Firefox auto updated from 17.0.1 to 18.0 and the stability is very poor. Crash occurs nearly immediately or a few seconds after launch every time. Adblock plus is the only addon and disabling it makes no difference. Although, Firefox 18 Safe mode does work without crashing, interestingly. I uninstalled and downgraded back to 17.0.1 and full stability is back. Version 18 and 18.0.1 are not ready in my opinion. I have not tried using a fresh profile.

UPDATE: FireFox 18.0.1 is also buggy and broken.

bp-e351a168-5b5c-4dcc-a7fa-1e2692130119 1/19/2013 4:45 PM

bp-de4730b6-4a16-4728-9674-1f6f52130119 1/19/2013 4:45 PM

bp-ce743869-bb12-4242-b125-994592130119 1/19/2013 4:44 PM


bp-c93e7c32-306a-401d-843e-3a0842130110 1/10/2013 4:56 AM

bp-5f76093c-9cbd-43f3-8067-2bad02130110 1/10/2013 4:56 AM

bp-cf23a9cd-969f-4f83-9d33-f6b832130110 1/10/2013 4:52 AM

bp-177717c4-bf27-44d5-9c93-cda9f2130110 1/10/2013 3:22 AM

bp-81a0d800-185e-4371-a9a7-224d42130109 1/9/2013 1:20 PM

bp-3c3aa8dd-45e7-4f00-b24d-1d92f2130108 1/8/2013 2:46 PM

bp-fabe18ff-27d3-4d90-b417-9ebf02130108 1/8/2013 2:41 PM

bp-30b367e9-3fd0-454b-b5a1-49fbd2130108 1/8/2013 2:30 PM

bp-8755acb5-67cc-40c6-9cf0-44e492130108 1/8/2013 2:30 PM

Modified by bluetickle

Chosen solution

Crash after crash... Hardware acceleration disabling doesnt solve. Please can U tell me how I can prevent auto-update to 18 version ? Thank you... about:crashes

bp-44eea239-cddd-4767-a1e8-b06442130111 11. 1. 20138:05f638e2f1-3839-45ce-a69b-e8b3fca5c9ea 11. 1. 20137:48c2a4e6f3-50f0-487c-9538-f6d8c148be5e 10. 1. 20139:12

Read this answer in context 👍 2

All Replies (14)

more options

What do I do with these 17.0.2 esr files? Do I need the linux and mac folders or just the win32?

more options

What's OS you're using? For windows use Win32 and then choose the language. That's it.

more options

Are you using a addon named 'showcase'?

more options

I am using windows, do not have showcase. I just don't get it. When I go to the link ftp://ftp.mozilla.org/pub/firefox/releases/17.0.2esr/ all I find is a bunch of files and folders. There's one labeled win32, filled with a bunch of subfolders. Nothing about selecting a language, nothing about installing FF17.02. What am I supposed to do with all these folders? How do I use them to install FF?

Firefox is really frustrating me, almost to where I am ready to switch to Chrome or (shudder) IE.

more options
more options

Oh, now it makes sense. Thank you!

more options

Firefox 18 update was a mistake. I had to uninstall and switch to Chrome. Where can I download and install version 17? I am using an HP dv7t laptop and they have not provided any updates since 2011. Maybe HP is lazy.

more options

kissglay thanks for that link, only problem is it is not working.

more options

Modified by Yousef

more options

Nevermind, I installed this one and it fixed the problem. It updated itself to 17.0.2.

I've uninstalled Mozilla Mantainance service to no more automatic browser updates for me. At least until they are able to fix that problem and make a stable update.

more options

I had the same problem and just now installed the latest beta 19.0. It seems stable so far.

more options

I wanted to give it a little time to make sure but version 18.0.1 has stopped crashing for me. I'm not sure why, but I think it was related to pressing the "Restore" button located in the nvidia control panel. Or it could be a coincidence, I'm not sure.

nvidia control panel/ manage 3d settings/ program settings/ mozilla firefox

more options

Like 'bluetickle' FF17.0.1 is fine with me. I upgraded to 18 and it immediately froze and crashed when I scrolled a page. Went back to 17.0.1, all was ok. Upgraded to 18.1 and that froze and crashed as well. Went back to 17.0.1 and guess what? It's running fine. I reset the profile and disabled all addons and plugins but didn't make any difference.

I'm staying with 17.0.1 until this is sorted or it's deemed unsafe to use.I have been using FF since it came out as I dislike MS software(IE) If it's decided my machine needs altering I'll use another browser that can use my existing setup.

If you buy a new door and it doesn'y fit you don't alter the house, you find a door that will fit!

more options

This seems a bit out there but...

In Win 7 64 bit, I entered the controlpanel on the below path: "Control Panel\Appearance and Personalization\Personalization\Window Color and Appearance"

Unchecked the "Enable transparency" and FireFox doesn't seem to crash anymore. Don't know why I did it, I just did :)

Modified by oneofj

  1. 1
  2. 2