X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

IN Windows 8 Desktop Mode, Firefox continually puts a background window over a new window when a new window is opened.

Posted

I am running Firefox in Windows 8 in Desktop mode. If I have a window open, and then open a new window, the previously opened window will open in front of the window just opened. If there is more than one window open when opening a new window, it is usually the most recently used window that opens in front of the new window, but not always. There can sometimes be a delay as well - I can begin to type in the new window, and the previously opened window will open again. I have tried various Option settings, but nothing seems to prevent this behavior. Occasionally, when I have several windows open at once, two or more windows may open on top of the freshly opened window.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Garmin Communicator Plug-In 4.0.4.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • NPWLPG
  • McAfee MSC FF plugin DLL
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Garmin Communicator
4.0.4
true
{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}
McAfee ScriptScan for Firefox
15.1.0
true
{D19CA586-DD6C-4a0a-96F8-14644F340D60}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.sessionstore.restore_on_demand
false
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
browser.tabs.loadInBackground
false
extensions.lastAppVersion
17.0.1
gfx.blacklist.direct2d
3
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1356886331
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD Radeon HD 7570
Vendor ID
0x1002
Device ID
0x675d
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.981.0.0
Driver Date
7-4-2012
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
DirectWrite Enabled
false (6.2.9200.16433)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
AzureCanvasBackend
cairo
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Type about:config in the URL bar and search browser.tabs.loadDivertedInBackground to false.

Question owner

When I looked up the setting, it was *already* set to false. Any other ideas?

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Helpful Reply

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

I tried the Firefox Safe Mode, and it prevented the problem from recurring. Now to Troubleshoot the extensions...

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Question owner

OK, I disabled extensions after the last post. I only have two extensions at this point - Garmin Communicator and McAfee Script Scan. For several days now, I have been switching between Safe Mode and Unsafe Mode (?) with extenstions disabled, which should be redundant. However, in Safe Mode I do not have the "old screen magically on top" problem, but I *do* have the problem with the extensions disabled if I don't start in Safe Mode.

Suggestions?

Question owner

Gee, Guys, I figured that someone would have said something by now... No ideas at all? I just have to live with the window problem?