X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash video stops playing after 10 to 12 seconds

Posted

Not sure when this started, but videos now will only play for about 10 - 12 seconds at a time. No crashes, no errors, just hangs and it's only the video. I can jump to another point in the video, and it will stop after 10-12 seconds from there. I'm on the latest Firefox with the latest version of Flash. I've tried uninstalling Flash using the Adobe uninstaller. I've reinstalled with 10.3, 11.2, and the latest again with no luck. I've turned off hardware acceleration, no luck. I've manually selected the resolution of the video, no luck. I've started in safe mode and enabled only the Flash plugin, no luck. Anyway have any ideas?

Chosen solution

I had tried the other two, but the middle one I hadn't seen. From that page I found that HTML5 videos don't play at all. So I checked my display drivers and they were from 2011. After updating them the issue is resolved, thanks for the help.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Unity Player 4.0.0f7
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • EA SPORTS Game Face Plugin 1.8.0.0
  • BlackBerry WebSL Browser Plug-In
  • Picasa plugin
  • Microsoft Lync 2010 Meeting Join Plug-in
  • 4.1.10329.0
  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Bing Search for Firefox
1
true
bing.search.for.firefox@firefox.bing
Cisco Click to Call
8.5.0
true
{be327679-1381-4aaa-93b3-4495c36762c5}
Collusion
0.24
true
jid1-F9UJ2thwoAm5gQ@jetpack
Java Console
6.0.37
true
{CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}
LastPass
2.0.0
true
support@lastpass.com
Reddit Enhancement Suite
4.1.2
true
jid1-xUfzOsOFlzSOXg@jetpack
Secret Server Firefox Utils
2.4
true
{db2e25d7-d802-4f1d-a909-f5540b5cd31c}
Tab Mix Plus
0.4.0.3.1
true
{dc572301-7619-498c-a57d-39143191b318}
RealDownloader
1.3.0
false
{34712C68-7391-4c47-94F3-8F88D49AD632}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.places.smartBookmarksVersion
4
browser.privatebrowsing.dont_prompt_on_enter
true
browser.search.useDBForOrder
true
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
browser.startup.homepage_reset
http://www.bing.com/?pc=MOZO
browser.tabs.insertRelatedAfterCurrent
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
17.0.1
font.internaluseonly.changed
false
keyword.URL
http://www.bing.com/search?form=MOZPLB&pc=MOZO&q=
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1357237794
places.history.expiration.transient_current_max_pages
98753
places.history.expiration.transient_optimal_database_size
158004182
privacy.cpd.extensions-tabmix
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics
Vendor ID
0x8086
Device ID
0x0042
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2509
Driver Date
8-31-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Helpful Reply

Maybe one of these pages will help?

https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems#w_troubleshooting

http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

http://kb.mozillazine.org/Flash#Troubleshooting

P.S. I see You already tried turning off hardware acceleration but was it in Firefox options or in Flash settings?

From the last help page:

Performance or display issues with certain Flash videos

Flash hardware acceleration can cause performance or display issues with certain Flash videos (e.g., high CPU usage, system instability, hangs, white or green screen, double image split by horizontal green line, no full-screen video, distortion, sound plays but no video). As a workaround, you can turn off hardware acceleration in your Flash Player display settings.

  1. Right-click on any Flash video or animation (or on the Flash logo on this Adobe help page).
  2. Click "Settings" and uncheck “Enable hardware acceleration" in the Display tab.

This may only be a temporary solution; however, since the Flash setting to turn off hardware acceleration is stored as an LSO (Flash cookie). Clearing cookies in Firefox also deletes this type of cookie (see bug 508167), as will using an extension such as BetterPrivacy, and that will turn hardware acceleration back on.

Modified by AliceWyman

Chosen Solution

I had tried the other two, but the middle one I hadn't seen. From that page I found that HTML5 videos don't play at all. So I checked my display drivers and they were from 2011. After updating them the issue is resolved, thanks for the help.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

I'm glad that the second link I posted, http://helpx.adobe.com/flash-player/kb/video-playback-issues.html got you pointed in the right direction.

Thanks for letting us know that you also had problems with HTML5 video and that updating your display drivers fixed your issues with both HTML5 and Flash videos.