X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 17.0.1 will not work with BBCiPlayer (but IE does)

Posted

When I try to view any tv show in iPlayer on my Dell Windows 7 machine I get a blank black screen. This is so with both catch-up programs and live ones. However, when I request viewing it in IE I have no problems at all. Interestingly I can view live tv in BBC iPlayer desktop ok. Also You tube videos work ok.

Chosen solution

Well that was simple, mind you everything is simple if you know how to do it!! I followed the first suggestion and disabled hardware acceleration in Firefox.

   Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" 

BINGO - PROBLEM SOLVED. THANK YOU SO MUCH.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • np-mswmp
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Amazon MP3 Downloader Plugin 1.0.17
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • GEPlugin
  • 4.1.10329.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.


You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Chosen Solution

Well that was simple, mind you everything is simple if you know how to do it!! I followed the first suggestion and disabled hardware acceleration in Firefox.

   Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" 

BINGO - PROBLEM SOLVED. THANK YOU SO MUCH.

Modified by gullrock25