X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Tabs are not saving, "restore previous session" is greyed out, showQuitWarning = true.

Posted

Problem started when I had a few windows open and I closed them and tried to open firefox in quick succession.

When I used to close firefox, it used to save my 800 tabs automatically, no message popped up when I closed, and when I opened firefox up again, all my tabs were there.

Now, when I close firefox, it warns me that I am closing 800 tabs. It gives me no option to save. When I open firefox back up, it doesn't let me "restore previous session," it is greyed out. However, I can go "recently closed windows" and use that to restore my session. Restarting firefox is also really slow now (I am not sure if it is closing or opening, but I suspect it is closing).

I have "show my windows and tabs from the last time" selected in options. I am not having it clear history on close. I set showQuitWarning, all options with "warnOn..." in them to true (only changed warnOnRestart), and privacy.clearOnShutdown.sessions to false.

I am not shutting down my computer until this is solved. These 800 tabs are important (will be about 500 after I finish culling, was 1365 yesterday).

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Nexon Game Controller
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Unity Player 3.5.6f4
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Google Analytics Opt-out Browser Add-on
0.9.6
true
{6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65}
Greasemonkey
1.5
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
NoScript
2.6.4.2
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
ProxTube - Unblock YouTube
1.4.3
true
ich@maltegoetz.de
Reddit Enhancement Suite
4.1.2
true
jid1-xUfzOsOFlzSOXg@jetpack
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.sessionstore.restore_hidden_tabs
true
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
dom.max_script_run_time
0
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1357018206
places.history.expiration.transient_current_max_pages
100090
privacy.clearOnShutdown.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics 4000
Vendor ID
0x8086
Device ID
0x0166
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version
8.15.10.2696
Driver Date
3-19-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics 4000) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/2 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the task manager.

Use "Firefox/File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") to close Firefox if you are currently doing that by clicking the close X on the title bar.


You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox Profile Folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

Dougo 0 solutions 3 answers

I had a problem with the "restore previous session" greyed out in history box too. The problem for me was hyper-threading, common in Pentium 4 processors. Easiest fix is to type "about:home" in the address bar, enter, and click on restore last session in the home page. You can also go to the Firefox icon, right click, click properties, click compatibility, and select "run this program in compatability mode for" and select Windows 98/Windows ME. This essentially disables hyper-threading. Also may be a good fix if Firefox hangs a lot. (You can also disable hyper-threading in BIOS, but this is overkill). You can also reboot your computer: this clears the hyper-thread in RAM. Or you can use a RAM manager like Free Ram XP Pro, to clear the RAM cache of the thread before you start Firefox. Or, you can go to task manager, right click on firefox.exe in processes tab, and if you have a dual/multicore processor, set affinity (number of processors to use) to 1. See ''''Solutions and Known causes of Fx Freezing'''' for instructions on how to keep affinity set to 1. (If you don't see the affinity option in task manager, you don't have a dual or multi-core processor). Or you can upgrade your BIOS. It may help, but that's kind of radical if this is the only problem you're having.

Modified by Dougo