Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is blocking id.washingtonpost.com. I use it all the time. This problem just started today. What's going on?

  • 1 reply
  • 4 have this problem
  • 101 views
  • Last reply by cor-el

more options

I have a blog sign-in on the Washington Post website. I use it all the time. Today, Firefox is blocking it, because it is an "Untrusted Website". I checked the page's certificate and it looks OK. I don't know why this is happening, but there seems to be no way to override the block. The dialog box won't even open fully. This is all I get This Connection is Untrusted



         You have asked Firefox to connect

securely to id.washingtonpost.com, but we can't confirm that your connection is

That's all it shows. Please fix this problem for me.

Chosen solution

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.