X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes several times a day. I have not found a pattern yet. It crashes randomly, I suppose.

Posted

Firefox crashes. I think Facebook is always running. I've tried in safe mode and with all plug-ins disabled but it keeps crashing randomly. Some days no crashes at all. Some days three crashes in one minute.

Chosen solution

This seems to have fixed the problem:

TCP/IP stack repair options for use with Vista or 7.

Start - All Programs - Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
avast! WebRep
7.0.1474
false
wrc@avast.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.be/
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
extensions.lastAppVersion
17.0.1
gfx.direct2d.disabled
true
gfx.direct3d.prefer_10_1
true
layers.acceleration.disabled
true
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1356366402
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 650 Ti
Vendor ID
0x10de
Device ID
0x11c6
Adapter RAM
1024
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
9.18.13.1070
Driver Date
12-3-2012
Direct2D Enabled
false
DirectWrite Enabled
false (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Ti) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
0
AzureCanvasBackend
cairo
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

We're sorry to hear that your Firefox seems to be crashing. Please perform the following steps to give us a crash report ID that helps us find out more about the cause of the crash.

  1. Enter about:crashes in the Firefox location bar (that's where you enter your website names) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the most recent 5 report IDs that you see in the crash report window and paste them into your forum response.

Thanks in advance for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Question owner

bp-182217c3-8260-42a2-be94-5b4402121228 bp-b1f5481d-de16-42d9-a702-8a9aa2121228 bp-c70ffba1-74c7-4848-8f95-6d0762121228 bp-6ad55b7a-6713-48a0-8ad8-614fc2121227 bp-7c642d16-aebf-4b16-b709-6c8982121226

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Question owner

I had already disabled the 'Use hardware acceleration when available' checkbox. Since my computer is brand new all my drivers are supposed to be up to date.

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

Helpful Reply

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

Firefox is now running in Safe Mode. Since I cannot predict when a crash will occur, I can never be sure the crashes don't happen in Safe Mode. When can I stop using Firefox in Safe Mode?

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

Its use to check, whether the problem with Firefox Addons or not....

What are the Addons are you using....

Question owner

The image contains the list of plugins.

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

List the Extension.
To stop Safe Mode. Firefox Menu - File > Exit.

Question owner

Firefox keeps on crashing. This is the crash-ID of the last crash: bp-22a93c95-2d8c-464e-8186-15c172121228

ideato
  • Top 25 Contributor
617 solutions 4263 answers

There is a possibility that the latest Firefox update wasn't successful.

Download a fresh new Firefox copy and save the file to the desktop from : http://www.mozilla.com/en-US/firefox/all.html

Uninstall your current Firefox version.

Don't remove your personal data when you uninstall the current version.

Remove the Firefox program folder before installing that new downloaded firefox copy.

It is also important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but be sure that you don't select to remove your personal data when you uninstall Firefox.

thank you

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

check this link [https://support.mozilla.org/en-US/que.../763731]

Chosen Solution

This seems to have fixed the problem:

TCP/IP stack repair options for use with Vista or 7.

Start - All Programs - Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine.

aprilr73 0 solutions 1 answers

Firefox keeps crashing randomly and in safe mode.

bp-ad20ec0b-31fb-4d5c-8ce1-e8ba92130226 2/25/2013 7:38 PM
bp-96ecc3d2-b9d2-42ce-a6f0-545632130226 2/25/2013 7:33 PM
bp-3fc79108-ef32-437d-99c6-c2e472130226 2/25/2013 7:32 PM
bp-6a1d8f9e-3cc2-4951-a1d8-4b0802130225 2/25/2013 4:15 PM
bp-d5e55fc3-4ecd-445e-9e44-7a2372130225

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Hi aprilr73

There is a problem on Windows 8 with Firefox 19 and AMD Radeon HD 6XXX/7XXX graphic display cards.

This issue is currently being investigated in bug 830531.

  • Bug 830531 - [Win8] crash in XPC_WN_Helper_NewResolve mainly with AMD Radeon HD 6290/6310/6320/7290/7310/7340

If you have one of those display cards then best is to stay with or downgrade to Firefox 18.0.2 for now or try the Firefox 20 beta version that doesn't seem to be affected.