X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

yahoo has hijacked my address bar

Posted

in firefox 18 my address bar seems to have been hijacked by yahoo ! or yahoo axis ! i prefer google so how do i change back to google ? i tried to go back to firefox 17 but the same thing happened . is it firefox or a virus ? i have a mac and ran antivirus and ccleaner but came up with nothing . very frustrating !!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • iPhoto6
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

in firefox 18 my address bar seems to have been hijacked by yahoo ! or yahoo axis ! i prefer google so how do i change back to google ? i tried to go back to firefox 17 but the same thing happened . is it firefox or a virus ? i have a mac and ran antivirus and ccleaner but came up with nothing . very frustrating !!

iamjayakumars
  • Top 10 Contributor
413 solutions 4897 answers

It sounds like you have a Third-Party Toolbar that has taken over your Search Engine, Home Page, and/or the Default New Tab Page. Fortunately this can be remedied easily:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the Remove button.
  5. Click Restart now if it pops up. Your tabs will be saved and restored after the restart.

After Firefox restarts, install the Search Reset Tool. This will remove the rest of the traces of this program from your Firefox.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Does this help your question? Let us know!

__________________________________________________________________________________

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.

Modified by iamjayakumars

walkercain 0 solutions 1 answers

Helpful Reply

The first suggestion did not correct the issue for me. The second suggestion contained only the first few steps to complete the fix.

To properly complete the fix: After typing “keyword.URL” in the Filter box, double-click or right click the entry and select modify. A prompt for Enter String Value (for keyword.url) will appear.

Copy & paste either of the google search strings below


Google’s I’m Feeling Lucky (Default Firefox address bar Search):

http://www.google.co.in/search?btnI=I%27m+Feeling+Lucky&q=

Google Web Search:

http://www.google.co.in/search?btnG=Google+Search&q=

Modified by walkercain

jacques.paul 0 solutions 1 answers

FireFox Mac solution to remove Yahoo toolbar The main problem is that Yahoo toolbar is invisible. To remove it:

Download EasyFind (in freeware) from that site: http://www.devontechnologies.com/download/products.html Install it. Close FireFox and Open EasyFind. On the right select MacIntosh HD. On the left select File & Folders, All words, and (most important) check Invisibles Files & Folders. Now enter Yahoo in the search field. The find result gone show Yahoo.xml in your FireFox/library/Application Support/FireFox/ profile folder/searchplugins. Select it and in the file menu clic destroy. Restart FireFox, Yahoo toolbar is not there anymore.

Modified by jacques.paul

ppltom 0 solutions 2 answers

Helpful Reply

Have a look at the link.

It has detailed information on how to fix this with pictures and steps. It is easier than you think.

How to change your browsers search

sylcha 0 solutions 1 answers

I am under OS X and I've followed your instructions, delete the 'yahoo.xml' file but each time Firefox (20.0) restarts the same 'yahoo.xml' file is created in the searchplugins folder. That's a serious hijack here! And I don't know what to do to prevent that!

The only thing I found is to delete my 'profile.ini' file and the associated folder to do as if Firefox was use for the first time...

Modified by sylcha