X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Dropdown menus work eratically on the DVI monitor in a dual monitor system

Posted

I'm using a dual monitor set-up with a HP pc. Firefox works perfectly with the main monitor but if I move the page to the DVI monitor the drop down menus do not display properly. They initially display but when I move my cursor over them the disappear. If I click over on one of the disappearing menu choices it execute the choice. Windows IE and Google Chrome work fine on the dual maonitor and Firefox worked fine initially also. ?It has been the last couple months or so it quite working properly.

Chosen solution

Try to disable hardware acceleration in Firefox.

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • NPWLPG
  • 4.1.10329.0
  • Picasa plugin
  • Windows Activation Technologies Plugin for Mozilla
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Telephony Toolbar
17.0
false
{318DDCC6-4A8F-4ad7-AFA8-F40F0D044C90}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
www.google.com
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1355444862
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 4200
Vendor ID
0x1002
Device ID
0x9710
Adapter RAM
256
Adapter Drivers
aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.862.3.0
Driver Date
6-29-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 4200 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Chosen Solution

Try to disable hardware acceleration in Firefox.

Question owner

Solved Thank you!

StephenB1204 0 solutions 4 answers

Helpful Reply

I too have this problem, or a similar one, which has just started over the last couple of days. I am on 15" MacBook Pro Retina with HDMI to an LCD HD TV. OS X 10.8.2

When I have the Firefox browser on the TV screen, drop down menus appear in miniature on the MacBook screen. I disabled the hardware acceleration and this seemed to work for the first instance of use but then the system reverted to miniature menu on the wrong screen.

Any ideas for curing this gratefully received.

acummings21 0 solutions 1 answers

I have the same problem as StephenB1204, using my 15" MacBook Pro Retina with HDMI to an LCD HD TV. Every mouse over or dropdown, etc. that I come across when browsing on my external monitor, they appear super tiny on the laptop. See attached.

StephenB1204 0 solutions 4 answers

I'm pretty sure that this has been happening since update to v18, on 11 Jan. This morning Firefox showed tab in top left corner of FFox window. Attempts to re size affect the entire window. See screenshot. The second screenshot shows minute drop down appearing on laptop screen rather than external monitor with Firefox window.

Trython 0 solutions 1 answers

Exactly the same issue is happening to me.

SPECS: MacBookPro Retina 15". Dual monitor setup.

THIS DOES NOT HELP: Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

dante1 0 solutions 2 answers

Hi there I too have the same problem as stephen B1204.

Has anyone solved this issue yet?

=]

StephenB1204 0 solutions 4 answers

Issue fixed with update 18.0.1 released 2 days ago. :-)

dante1 0 solutions 2 answers

really i have that update but it still happens to me =[