X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mouse wheel to scroll document no more works (Linux - Firefox and Seamonkey)

Posted

Hello,

This is a regression because it worked well in one or two previous version.

I would like to scroll the document (one full page per mouse wheel). This configuration does not work : mousewheel.withnokey.action = 1 mousewheel.withnokey.sysnumlines = false Changing these values does nothing.

More easy with seamonkey : "preferences/advanced/mouse wheel/scroll the document" does nothing !

A bad workaround : - mousewheel.min_line_scroll_amount = 999 : it works well !! - But the arrows of the vertical scroll bar moves 999 lines ! It is funny that a parameter of the mouse wheel does something on the scrollbar...

It seems that the are 2 problems : - mouse wheel to scroll the document no more works - parameter mousewheel.min_line_scroll_amount changes the scroll bar behavior

This is on linux.

Before reporting a bug I ask to know if I missed something...

Thanks.

Modified by ecforum

Chosen solution

With your workaround and the bug 801101 you give the solution : mousewheel.default.delta_multiplier_y;9999 with the setting "scroll content" mousewheel.default.action;1

This works !

I also deleted 3 old configs that are not automatically deleted : mousewheel.withnokey.action;1 mousewheel.withnokey.numlines;10 mousewheel.withnokey.sysnumlines;false I don't know if it is important but if somebody read this thread it will maybe help.

Setting the multiplier seems needed. mousewheel.withnokey.action;1 has not the correct behavior alone. In seamonkey, "preferences/advanced/mouse wheel/scroll the document" does not set the multiplier so it does not work. It works after setting the multiplier manually.

I can again scroll big documents or photo galleries easily ! :)

I was unable to find a solution alone even reading on the net. That's why I was ready to report a bug.

Thanks Cor-el for finding a solution ! :):):)

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Scalable Vector Graphics, as handled by RSVG-2.26.0. Views SVG images.This is alpha software. It will probably behave in many situations, but may also ride your motorcycle, drink all your milk, or use your computer to browse porn. Comments, feature requests, and patches are welcome.See http://librsvg.sourceforge.net/ for information.
  • Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version 0.4.0.5174 built with gcc 4.1.2 on Oct 6 2009
  • mplayerplug-in 3.55Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer JavaScript Enabled and Using GTK2 Widgets

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0 SeaMonkey/2.14.1

More Information

Question owner

In this link I read : Customizing default action of "wheel" event. The value 0 means "Do nothing", 1 means "Scroll contents", 2 means "Go back or forward in the history", 3 means "Zoom in or out the contents".

mousewheel.default.action = 1 in my config...

Question owner

The last line in the firefox 17 paragraph is : "On Linux, the scroll unit is always by line. "

I do not understand the paragraph (my english and my knowledges...). Does this mean that there is no content scroll on linux ?

Thanks

Modified by ecforum

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

The delta_multiplier are internally floats of type double and are converted to an integer for storing in a pref by multiplying them with 100 and are acting as percentages of the default scroll amount (i.e. 100 -> 1).

Set the mousewheel.default.delta_multiplier_y pref to 33 to change the scroll behavior from 3 lines to 1.

You can also try this:

  • mousewheel.system_scroll_override_on_root_content.enabled -> true

Question owner

Nothing changes with the last try.

Do you know if it works on linux ? Maybe the problem is only for me... But I tested on 2 systems with several logins... [edit] and with firefox and seamonkey...

Modified by ecforum

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Maybe reserve the Shift modifier for this.

  • mousewheel.with_shift.action;2 1
  • mousewheel.with_shift.delta_multiplier_y;9999


(edit: fixed action value from 2 to 1)

Modified by cor-el

Question owner

a typo : mousewheel.with_shift.action;1

It's a good workaround ; the arrows of the scroll bar still work.

I think I will report a bug and the developers will decide if it is a real problem.

Thanks Core-el for your answers. It's a real help and you have found a good workaround. Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You're welcome

Oops, I copied the pref setting from the wrong Firefox instance (I had two extra copies open and had tested this in one).

See also:

  • bug 801101 - Needs a option to scroll over one page

Modified by cor-el

Chosen Solution

With your workaround and the bug 801101 you give the solution : mousewheel.default.delta_multiplier_y;9999 with the setting "scroll content" mousewheel.default.action;1

This works !

I also deleted 3 old configs that are not automatically deleted : mousewheel.withnokey.action;1 mousewheel.withnokey.numlines;10 mousewheel.withnokey.sysnumlines;false I don't know if it is important but if somebody read this thread it will maybe help.

Setting the multiplier seems needed. mousewheel.withnokey.action;1 has not the correct behavior alone. In seamonkey, "preferences/advanced/mouse wheel/scroll the document" does not set the multiplier so it does not work. It works after setting the multiplier manually.

I can again scroll big documents or photo galleries easily ! :)

I was unable to find a solution alone even reading on the net. That's why I was ready to report a bug.

Thanks Cor-el for finding a solution ! :):):)

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You're welcome and thanks for reporting your findings.