X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My updated versions of Firefox have displayed only a few buttons on websites. How can I correct this?

Posted

Whenever I use any of the updated versions to access a website that is interactive, whether it's a shopping page such as Amazon or Target, etc, or a personal page, such as Kaiser Permanente or a financial website, the page doe not display all the buttons properly. Some of them are missing. I cleared my cookies and cache and checked to see that Java was enabled and I don't have a firewall or other application that would interfere with Java. I have not tried to reset Firefox to it's basic "factory issued" mode yet, but before I do that, is there anything else I should try? I use an imac desktop with OSX version 10.6.8 currently.

Chosen solution

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • RealPlayer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Michalis 18 solutions 193 answers

Chosen Solution

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

Thank you for your help resolving this problem. I went to the Help Menu and chose Restart in the Safe Mode, but when Firefox restarted, I still had buttons missing.

Then I redid the Safe Mode but chose to reset Firefox to its basic mode and that worked for me. Firefox still was able to save my bookmarks and the bookmarks along the toolbar as well as latest headlines, weather, etc.

I will play with it more to see if I can find out what specific add on was affecting the buttons when I have a chance.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

This can also be caused by disabling colors and backgrounds or by blocking images.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"