X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

google search does not work with java script enabled

Posted

Google Search does not work with Java script enabled. This happened after the recent update to Firefox 17 .0.1.I have to constantly enable/disable java script when using the internet.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Facebook Video Calling Plugin
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check if DOM Storage is enabled.

You can check the dom.storage.enabled pref(s) on the about:config page.

sumguy 0 solutions 7 answers

I have this problem when I have google cookies blocked. It started very recently. Going to safe mode doesn't help. dom storage is enabled.

With Javascript on, if I do a search in the search field at the top of the google page, or I try to go to the next page in the search results, the page doesn't load. I only see the same page, with the previous results grayed out.

A quick workaround is to a) allow the google cookie (not an option for me, because I don't want to be tracked), or b) turn off javascript. I used the "yes script" addon to turn it off just for google.

Hopefully this can be fixed. It works fine in Safari with cookies blocked and javascript on.

sumguy 0 solutions 7 answers

this seems to have been fixed now, by google...

rubicon1 0 solutions 1 answers

I still have this problem! Also in Save mode.

Please send me a clear instruction.