X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

google search on www.google.com does not show any results, searching from the search box works (I use ESR 10.0.11)

Posted

If I search with google from the search box results show up. Being on the google page I then enter another search term in the search box at the top of the page but pressing enter or clicking the search icon does not do anything. When typing in the search field I see googles auto-suggestions which makes the thing even stranger. If I click the "Images" tab the search is performed and if I click back on the search tab when seeing the image results also performs a search. I have already cleared my cookies and all my other private browsing items but no change. The scriptblocker extension also shows no blocked sign on the google page. I use FF ESR with the same addons on my XP desktop and on my w7 notebook. About 3 days ago everything used to work fine on both devices. Since then I notice the problem only on my XP box, the notebook still works as before.

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 4.0.4.0
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • PDF-XChange Viewer Netscape Gecko Plugin
  • 4.1.10329.0
  • GEPlugin
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Shockwave Flash 10.3 r183
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Dll file of HP Virtual Room Client Launcher Plugin for Firefox, Chrome, and Safari
  • Office Live Update v1.5
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1739

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.11) Gecko/20100101 Firefox/10.0.11

More Information

philipp
  • Top 10 Contributor
  • Moderator
2050 solutions 8916 answers

Helpful Reply

hello latimer, there have been quite a few similar reports of that issue, but no definite answer found yet what did cause (probably a code change on google's server side) & what will cure the issue, as far as i know.

always a good way to start is to clear the cache & cookies from google.com and then reload the page.

some users have reported that the issue might have been caused when the dom.storage.enabled preference in about:config was set to false. [source]

other users have reported that the search problem only appeared when they had firefox set to block cookies from google.com or one of its local domains. can you check if this is the case for you when you go into firefox/tools > options > privacy > accept cookies - exceptions...

another possible solution might be to disable javascript on google to make the search work again. alternatively you might use the firefox search bar to do a google search or use https://www.google.com/webhp?complete=0 until this is somehow addressed by google...

jscher2000
  • Top 10 Contributor
2382 solutions 21079 answers

Does it make any difference if, in Google's search settings page, you change the setting for Google instant predictions to "Never show Instant results"?

Earlier this year there was an odd problem with Facebook for users who set their cookie handling to "Ask me every time." The problem seemed to be that approving cookies in that dialog also granted local storage permissions, but for www.facebook.com instead of facebook.com, which was what was needed. Manually creating a cookie exception for the base domain seemed to resolve the issue.

Question owner

Hello madperson, The dom.storage.enabled did the trick. In fact it was set to false on my XP box and to true on my w7 notebook. I do not know if it has been always false on my XP box or if something has changed it lately but now it is working again. Thanks a lot for your quick and helpful answer.

Helpful Reply

Strange things still go on. I disabled instant search results and now the google search window refreshes constantly. I cannot even revert to enable instant search because the google settings refresh too quickly to do the change. That is really weird and I do not know how to get FF back to working correctly now.

Question owner

Got it back to working. I logged in to my google account which stopped the constant refreshing of the window. Then I was able to set the "instant search" mode again. I again cleared all my private browsing items and now google behave normally again. I still do not know exactly what has happened but I am going to stop investigating because I do not want to screw up running system again.