X
Tap here to go to the mobile version of the site.

Support Forum

I put dom storage on "false" and now I can't do a Google search. A few days ago I could search Google with dom on false. What changed?

Posted

I customized the Firefox using 'about:config' and all the other settings work well with Google search - for example geo_enabled which I set to false.

The one setting that has suddenly proved problematic is dom_storage. I used it in false mode successfully for months when searching on Google, now the setting has resulted in an inability to search on Google. The Google page with search bar comes up as usual when I open the browser, but with dom storage set to "false" I can't search anything - the Google search bar page just remains static.

I customized the Firefox using 'about:config' and all the other settings work well with Google search - for example geo_enabled which I set to false. The one setting that has suddenly proved problematic is dom_storage. I used it in false mode successfully for months when searching on Google, now the setting has resulted in an inability to search on Google. The Google page with search bar comes up as usual when I open the browser, but with dom storage set to "false" I can't search anything - the Google search bar page just remains static.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • 4.0.50401.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

finitarry
  • Top 25 Contributor
214 solutions 3102 answers

That seems a bit strange, unless google.ca works differently from google.com. I have dom.storage.enabled set to false, and with google.ca, I still get search results. I always get google.ca because I am in Canada.

That seems a bit strange, unless google.ca works differently from google.com. I have dom.storage.enabled set to false, and with google.ca, I still get search results. I always get google.ca because I am in Canada.
philipp
  • Top 10 Contributor
  • Moderator
2953 solutions 13759 answers

hello, some other users have reported that the search problem only appeared when they had firefox set to specifically block cookies from google.com or one of its local domains. can you check if this is the case for you when you go into firefox/tools > options > privacy > accept cookies - exceptions...?

alternatively you might use the firefox search bar to do a google search or use https://www.google.com/webhp?complete=0 until this is somehow addressed by google (provided that this was not an intentional change).

hello, some other users have reported that the search problem only appeared when they had firefox set to specifically block cookies from google.com or one of its local domains. can you check if this is the case for you when you go into ''firefox/tools > options > privacy > accept cookies - exceptions...''? alternatively you might use the firefox [[Search bar - Easily choose your favorite search engine|search bar]] to do a google search or use https://www.google.com/webhp?complete=0 until this is somehow addressed by google (provided that this was not an intentional change).
allandeveryone 0 solutions 3 answers

Helpful Reply

i have the same problem.dom storage and third party cookies are disabled and i cant search in google neither. a workaround is change your user agent (explorer 9 works fine) or disable javascript

i have the same problem.dom storage and third party cookies are disabled and i cant search in google neither. a workaround is change your user agent (explorer 9 works fine) or disable javascript
beachmarathoner 1 solutions 16 answers

>specifically block cookies from google.com or one of its local domains. >can you check if this is the case for you when you go into firefox/tools > >options > privacy > accept cookies - exceptions...?

This is not the case for me. I have my Privacy set to >accept cookies from sites >accept third party cookies >keep until I close firefox and google has also stopped working for me. DuckDuckGo, Bing, Yahoo all function fine and I'm not happy about turning DOM settings back to true for google.

''>specifically block cookies from google.com or one of its local domains. >can you check if this is the case for you when you go into firefox/tools > >options > privacy > accept cookies - exceptions...? '' This is not the case for me. I have my Privacy set to >accept cookies from sites >accept third party cookies >keep until I close firefox and google has also stopped working for me. DuckDuckGo, Bing, Yahoo all function fine and I'm not happy about turning DOM settings back to true for google.
finitarry
  • Top 25 Contributor
214 solutions 3102 answers

Disabling javascript for Google works like a charm. No need to allow them to set cookies or use DOM storage. Of course, since Start Page uses Google search, you could use that engine instead, and do away with the snooping altogether.

Disabling javascript for Google works like a charm. No need to allow them to set cookies or use DOM storage. Of course, since Start Page uses Google search, you could use that engine instead, and do away with the snooping altogether.
beachmarathoner 1 solutions 16 answers

To use my Start Page Google search and go beyond the first page of results, I have to click the next page (which blanks the page) then click reload before the next page of results will come up.

To use my Start Page Google search and go beyond the first page of results, I have to click the next page (which blanks the page) then click reload before the next page of results will come up.
jscher2000
  • Top 10 Contributor
3141 solutions 28885 answers

Helpful Reply

Users who disable DOM storage in IE8 and IE9 are reporting the same problem on Google's web search forum. For that reason, the requirement to allow DOM storage sounds like a change in Google's code rather than a browser-specific issue.

One Firefox-specific issue is the cookie connection: Firefox appears to use cookie permissions to block DOM storage on a site-by-site basis. So if you block cookies for google.com, the DOM storage problem will kick in.

Users who disable DOM storage in IE8 and IE9 are reporting the same problem on Google's web search forum. For that reason, the requirement to allow DOM storage sounds like a change in Google's code rather than a browser-specific issue. One Firefox-specific issue is the cookie connection: Firefox appears to use cookie permissions to block DOM storage on a site-by-site basis. So if you block cookies for google.com, the DOM storage problem will kick in.
Oxylatium 43 solutions 296 answers

Google fixed the issue about cookies blocked, see https://bugzilla.mozilla.org/show_bug.cgi?id=820389

Google fixed the issue about cookies blocked, see https://bugzilla.mozilla.org/show_bug.cgi?id=820389