X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't paste text at the WYSIWIG editor in FireFox 17.01

Posted

After the upgrade to FireFox 17.01 the HTML WYSIWIG editor restricts some actions; by example cut/copy and paste.

The editor suggests in the past 4 steps to enable those actions but does not works with this version.

Any clues?

Thanks.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • VLC media player Web Plugin 2.0.2
  • Facebook Video Calling Plugin
  • Facebook Desktop Plugin
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • LightshotPlugin
  • BlackBerry WebSL Browser Plug-In
  • GEPlugin
  • 5.1.10411.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20927 answers

Which editor is it? E.g., ckeditor, TinyMCE, etc.

There was a change in how Firefox 17 identifies itself to websites. This has created problems for some scripts. If the editor works in the beta version, Firefox 18, that might be the problem.

http://www.mozilla.org/en-US/firefox/beta/

If you want to try the beta version, I suggest making a backup of your Firefox settings (profile folder) first. One way to quickly access that folder is:

Help > Troubleshooting Information > "Show Folder" button

Navigate up one level, then copy your entire randomly named folder somewhere outside the Mozilla folder for safekeeping.

Any luck?

jscher2000
  • Top 10 Contributor
2365 solutions 20927 answers

Helpful Reply

If the problem is with the editor's buttons, could you provide a link to the relevant instructions?

If the problem is with Firefox's native functionality --

  • Right-click Cut, Copy, Paste
  • Ctrl+x, Ctrl+c, Ctrl+v
  • Edit menu Cut, Copy, Paste

-- then it could be that the site's scripts are intercepting those actions and not allowing them to complete. To disable sites from altering those command, you can change a preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste clipb and pause while the list is filtered

(3) Double-click dom.event.clipboardevents.enabled to switch its value to false. You're done with this tab.

You might need to reload the page in order for this to take effect.

Question owner

Hi Jscher2000,

I'm using an CMS called cowadmin. This application use DevEdit NX 1.5 as HTML editor.

Before the last update of FireFox the editor works fine, but not now. This is an old software without support from a dead company so I can't change the way it works or upgrade to a new version of the editor.

They made a tutorial to enable this features in FireFox but apparently does not work with this version...

I'm still trying to make it works again.

Question owner

The problem is with the editor's buttons. They provide this instructions to enable the restricted features:


Enabling Restricted Features in FireFox

If you're using a Gecko based web browser, such as FireFox or Mozilla, you will need to enable a security option in order to use some functions inside the HTML editing component. These include Cut, Copy and Paste using the toolbar icons. To do this, simply follow this 3 step process:

Step 1. Type in about:config into the URL bar in your FireFox browser and press enter.

Step 2. Scroll down until you see the following option in the list: "signed.applets.codebase_principal_support"

Double click that option and it will turn bold indicating that it is now on.

Step 3. Go back to your HTML editing control and refresh the screen. A popup security dialog window will appear. Select the "Remember this decision" option and click "Allow".

Step 4. Close all your FireFox browser windows and restart the browser. You're HTML control should now have all the options enabled in FireFox.


Steps 1 and 2 are done, but when I refresh the screen nothing happens. At this point I can't continue...

jscher2000
  • Top 10 Contributor
2365 solutions 20927 answers

The dialog is a little hard to read, but why would they want permission to install software on your machine? Sounds sketchy to me. I think it would be safer to use the 3 built-in methods and forget about those buttons.

jscher2000
  • Top 10 Contributor
2365 solutions 20927 answers

Based on further research, some or all of the enablePrivilege mechanism may have been removed or disabled in Firefox 17. I wasn't able to read through all the related "bugs" but a very general summary and workaround are in this page:

https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_17#Security

It's probably a bad idea to set the global preference "security.enablePrivilege.enable_for_tests" to true while browsing the wilds of the web, but you could set it to true while administering your CMS and see whether that works, then switch it to false for normal browsing.

To emphasize that this is a dangerous setting, in Firefox 19, it will be renamed to "security.turn_off_all_security_so_that_viruses_can_take_over_this_computer".