X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why are cookies not deleted when I close Firefox?

Posted

Hey,

My problem is that I set Tools / Options / Privacy / History to "Use custom settings for history", and then under cookies I set Keep until: to "I close Firefox".

Yet, when I close my browser and restart none of the cookies are deleted. If I save my tabs, I stay logged in on the websites that are open on the saved tabs. But even if I close the website, and then quit. And then reopen the website after launching Firefox again, I am still logged in. Whereas Firefox is set not to remember any of my usernames or passwords, so the only way this can happen is via cookies. Therefore, the cookies are not deleted. But I can also see it in the list of cookies: it's full of old stuff.

So why are cookies not deleted despite this setting?

Firefox has beeen pretty soft on privacy lately, and frankly I don't understand why. The possibility to have history older than X days automatically deleted has also been gone for a long time, and now this cookie setting doesn't work, either.

Chosen solution

If you reopen tabs automatically the next time then Firefox stores cookies from those tabs by default as part of the session data in the sessionstore.js file.

You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • npFFApi
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.9.12
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
ZoneAlarm Security Engine
1.5.380.0
false
{FFB96CC1-7EB3-449D-B827-DB661701C6BB}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.search.useDBForOrder
true
browser.startup.homepage
http://www.foxnews.com/
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
browser.tabs.autoHide
true
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1354207528
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics Family
Vendor ID
0x8086
Device ID
0x0106
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version
8.15.10.2559
Driver Date
10-21-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8899 answers

hello Ansings, the "Keep until: I close Firefox" setting might only work for newly acquired cookies - the cookies already present will stay until they reach their originally set expiry date, therefore you would have to manually delete all old cookies once so that the setting works fully as you intended.

(older versions of zonealarm might also interfere with the cookie management in firefox, but i don't know if this is the case on your system - http://kb.mozillazine.org/Websites_report_cookies_are_disabled...)

Question owner

Hi madperson,

I turned this setting on a long time ago. Basically, it's one of the first things I do after installing my OS and Firefox. So there shouldn't be so many old cookies there.

But anyways, just now I deleted all the cookies manually via Tools / Options / Privacy / Show Cookies / Remove All Cookies to be sure that all the old stuff is wiped out. And yet it still doesn't work.

I logged in to my Gmail account (the Remember Me box ain't checked), closed the tab containing my Gmail account and then closed Firefox. After that I verified in the Task Manager that firefox.exe is indeed not running anymore. So Firefox definitely shut down properly. Then, I restarted Firefox and opened a tab, entered gmail.com, and I was still logged in, therefore the cookies were not deleted.

I have the 10.1.101.000 version of ZoneAlarm, which as it turns out after googling it is indeed not the latest version (it was released in March 2012). The ZoneAlarm Firefox add-on that automatically comes with the firewall is disabled in Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

If you reopen tabs automatically the next time then Firefox stores cookies from those tabs by default as part of the session data in the sessionstore.js file.

You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

Question owner

Thank you! This is it! The "Keep cookies until: I close Firefox" setting seems to change browser.sessionstore.privacy_level_deferred to 1. So it only applies to non-HTTPS pages, that's why I stay logged in on Gmail and stuff. So I changed it to 2, and it works now.

Still I don't understand why I have to go to about:config for such basic issues, why can't this be set in a more straightforward way in the Options? There should be like an advanced options or something for stuff like this. Just a suggestion.

Thanks again for both answers, y'all.

crabpaws 0 solutions 8 answers

I couldn't agree more with Ansings.

I do NOT have "Show my windows and tabs from last time" set and I cannot delete cookies manually or any other way. When I delete them manually, they appear to go away but appear again in a couple of minutes.

Which of the about:config settings (1 or 2) would apply -- I want to selectively delete the darned cookies -- and where the heck is about:config and how do I edit it?