Question

downloaded last 2 versions neither registers as there-for example add on message says: This Persona requires Firefox 3.6. You are currently using Firefox 3.5.7.

I downloaded version 17 today- -i checked it several times-and tried unpacking it 3 different times--thinking it shorted out somewhere and didn't tell me Facebook has been telling me for weeks that I have an older version of the browser that doesn't support FB and I should upgrade. Tried to add a persona and get this message This Persona requires Firefox 3.6. You are currently using Firefox 3.5.7..

Please help! I can't watch your videos because dial up is so basic. I am home with health problems so going out now to coffee shops, etc not possible. Thank you!

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post