X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop FF from restoring previous session, I've already played with all the options I can find but nothing stops it unless I delete history each time.

Posted

Recently, FF has started opening my last tabs when I start a fresh session. I have already checked to make sure that none of the applicable settings are enabled, such as under Options->General: When FF starts "SHOW MY HOMEPAGE" is selected. But for some reason, it opens my last session. The only way I've been able to get it to stop doing this is by having it delete my browsing history after I close the session. I don't want this since I often use my history to re-find information I need for class research. I have made certain that all my settings are the same from before FF started doing this. It only started doing this after the computer was turned off for a long weekend.

I've already searched through the Mozilla help pages and all I can find is how to restore the previous session or similar. I don't want to restore my previous session, I want it to stop restoring my previous session without having to delete my browsing history each time.

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 4.1.10329.0
  • DivX Plus Web Player version 2.2.0.52
  • GEPlugin
  • DivX VOD Helper Plug-in
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

I have attempted restarting FF, upgrading (16->17), uninstall/re-install, along with changing and returning my options values via Firefox->Options. Below is the copy/paste from Help->Troubleshooting Information as requested by the form page.
Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Norton Family
2.6.0.52
true
{6D5C8FC4-DE46-41bf-9092-93F0F78E9115}
Norton Toolbar
2012.5.8.3
true
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Norton Vulnerability Protection
11.1.1.5 - 3
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
StumbleUpon
4.15
true
{AE93811A-5C9A-4d34-8462-F7B864FC4696}
DataMngr
1.0
false
{1FD91A9C-410C-4090-BBCC-55D3450EF433}
DivX Plus Web Player HTML5 <video>
2.1.2.145
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
FoxFilter
7.6.4
false
foxfilter@inspiredeffect.net
HP Smart Web Printing
4.60
false
smartwebprinting@hp.com
Rikaichan
2.07
false
{0AA9101C-D3C1-4129-A9B7-D778C6A17F82}
Zotero
3.0.8
false
zotero@chnm.gmu.edu
Important Modified Preferences
Name
Value
accessibility.blockautorefresh
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage
https://startpage.com/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
extensions.lastAppVersion
17.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353888927
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.promptOnSanitize
false
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD Radeon HD 6700 Series
Vendor ID
0x1002
Device ID
0x68ba
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
9.2.0.0
Driver Date
9-27-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (AMD Radeon HD 6700 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

finitarry 157 solutions 2177 answers

If you set Firefox to open a home page when it starts up, that should fix it. If you do not want to see a particular page as the home page, you can set that to about:blank. Do that at Options > General.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96755 answers

Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the task manager.

See:

Use "Firefox/File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") to close Firefox if you are currently doing that by clicking the close X on the title bar.

You can set the Integer pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first restart after a crash has occurred or the Task Manager was used to close Firefox.

That way you see if a sessions has crashed or otherwise didn't close properly and will allow you to deselect the tab(s) that you do not want to reopen, but will allow to reopen other tabs.

Question owner

@Finitarry: I already have a website set as my default (and startup) page. I have also tried to change and then return this option to no avail.

@Cor-el: FF is not crashing or hanging (tested using the max_resumed_crashes setting). Also, as per Task Manager, when I exit out of FF (using either the red 'x' in the upper right corner, or Firefox->Exit) the process closes down and ends entirely.

I'm sorry, folks, but neither of these proposed solutions did anything to help. FF still re-opens the last session even though all settings are telling it not to.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96755 answers

Chosen Solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

Question owner

@Cor-el: I created a new profile and it no longer returned to the old session. Thank you. I even tried loading addons into FF to see if I could cause it to return to the problem and so far it has stopped entirely.

KrisMouse 0 solutions 1 answers

Helpful Reply

Using the instructions here: http://kb.mozillazine.org/Session_Restore#Disabling_crash_recovery

I was able to turn off that feature entirely without having to create a new profile.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96755 answers

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

Modified by cor-el