X
Tap here to go to the mobile version of the site.

Support Forum

How do I get Firefox to check addon compatibility first, then ask me if I want to continue the Firefox update?

Posted

How do I get Firefox to check add-on compatibility first, then ask me if I want to continue the Firefox update? The update process currently only tells me that an add-on has been disable after applying the Firefox update. The Options > Advanced > Update tab switch, "Warn me if this will disable any of my add-ons", does not seem to work.

How do I get Firefox to check add-on compatibility first, then ask me if I want to continue the Firefox update? The update process currently only tells me that an add-on has been disable after applying the Firefox update. The Options > Advanced > Update tab switch, "Warn me if this will disable any of my add-ons", does not seem to work.

Chosen solution

delores51

Here is an add-on which does that.
https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/

Specifically, which add-ons are always showing up as incompatible after a Firefox update? As of Firefox 10, extensions which are properly made shouldn't pose a problem, with a few exceptions.

Extension which contains binary code have to be compiled for each new version of Firefox. Those add-ons typically are installed by security suite applications like Norton, McAfee, ZoneAlarm, etc.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • VMware Remote Console and Client Integration Plug-in
  • Microsoft Lync 2010 Attendee Meeting Join Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

I have restored to Firefox 16.0.2 several times and tried different update options, but none have warned me prior to installing the Firefox 17 update. I want to use the "Tab Mix Plus 0.4.0.3" add-on, which is disabled by Firefox 17.
This type of update behavior (check add-on compatibility first) was available in prior versions of Firefox.

ideato 893 solutions 6250 answers

Hello BigErnie, i see in your Additional System Details/More Information that you want Tab Mix Plus , see : Tab Mix Plus is incompatible with Firefox 17 - Use the development build as a workaround


thank you

Hello BigErnie, i see in your Additional System Details/More Information that you want Tab Mix Plus , see : [https://support.mozilla.org/en-US/kb/tab-mix-plus-incompatible-firefox-17-use-dev-build Tab Mix Plus is incompatible with Firefox 17 - Use the development build as a workaround] thank you
dolores51 1 solutions 7 answers

Helpful Reply

How do we check that new versions of FF are compatible with our existing Add-ons? I'm really quite over always having half of them not working after updating FF. It's very frustrating. Couldn't there be an option in the Add-ons menu that checks if they're compatible with a new version? Thanks.

How do we check that new versions of FF are compatible with our existing Add-ons? I'm really quite over always having half of them not working after updating FF. It's very frustrating. Couldn't there be an option in the Add-ons menu that checks if they're compatible with a new version? Thanks.
the-edmeister
  • Moderator
5027 solutions 37054 answers

Chosen Solution

delores51

Here is an add-on which does that.
https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/

Specifically, which add-ons are always showing up as incompatible after a Firefox update? As of Firefox 10, extensions which are properly made shouldn't pose a problem, with a few exceptions.

Extension which contains binary code have to be compiled for each new version of Firefox. Those add-ons typically are installed by security suite applications like Norton, McAfee, ZoneAlarm, etc.

delores51 Here is an add-on which does that. <br /> https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/ Specifically, which add-ons are always showing up as incompatible after a Firefox update? As of Firefox 10, extensions which are properly made shouldn't pose a problem, with a few exceptions. Extension which contains binary code have to be compiled for each new version of Firefox. Those add-ons typically are installed by security suite applications like Norton, McAfee, ZoneAlarm, etc.
dolores51 1 solutions 7 answers

Thanks for replying Ed. The last few times I updated FF about half the add-ons didn't work, so I ended up deleting them. The ones I remember not working then and which I now have are Net Usage Item, Image Toolbar and Australian Dictionary. There were others, but I've since lost them as I couldn't use them, which is why I've been reluctant to upgrade again. Cheers.

Thanks for replying Ed. The last few times I updated FF about half the add-ons didn't work, so I ended up deleting them. The ones I remember not working then and which I now have are Net Usage Item, Image Toolbar and Australian Dictionary. There were others, but I've since lost them as I couldn't use them, which is why I've been reluctant to upgrade again. Cheers.

Modified by dolores51

Question owner

Thanks ideato. I will definitely look into the Tab Mix Plus development build.

Thanks ideato. I will definitely look into the Tab Mix Plus development build.

Question owner

I am also going to look into the "is-it-compatibile" add-on.

The funny thing is that, in the past, FireFox did check the add-ons before applying the updates.

Thanks Ed

I am also going to look into the "is-it-compatibile" add-on. The funny thing is that, in the past, FireFox did check the add-ons before applying the updates. Thanks Ed
ideato 893 solutions 6250 answers

Tab Mix Plus NEW version 0.4.0.3.1 is available and reportedly fixes the bugs that made it not compatible with Firefox 17 see : https://support.mozilla.org/en-US/forums/contributors/708781?last=49574#post-49572

thanks

Tab Mix Plus NEW version 0.4.0.3.1 is available and reportedly fixes the bugs that made it not compatible with Firefox 17 see : https://support.mozilla.org/en-US/forums/contributors/708781?last=49574#post-49572 thanks
Andy_P 0 solutions 12 answers

the only trouble with the suggested add-on which checks compatibility, is that it only seems to check whether things SAY they are compatible.

One of my favourite add-ons (Edit Bookmarks Plus 2.3.0) is said to be compatible, but as soon as I updated to Firefox 18 it stopped working properly.

the only trouble with the suggested add-on which checks compatibility, is that it only seems to check whether things SAY they are compatible. One of my favourite add-ons (Edit Bookmarks Plus 2.3.0) is said to be compatible, but as soon as I updated to Firefox 18 it stopped working properly.