Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

general.useragent.locale setting ignored

  • 4 replies
  • 2 have this problem
  • 2590 views
  • Last reply by tonyr63

more options

From my desktop PC running windows 7 SP2 and Firefox 5.0.1 when I use Google search I get results from the UK even though I live in Australia and have my location details set in Windows to Australia.

I have edited general.useragent.locale to en-au and intlaccept_lanuage en-au,en and still I canot get result from Australia

I have alos set the intl to use OS settings but still it is not working properly

All Replies (4)

more options

The general.useragent.locale pref is only used to select a specific locale if you have installed more than one locale in Firefox.

Firefox no longer adds the locale to the user agent, so that pref doesn't have effect.

Do you have the en-GB Firefox version installed or another English version?

Which Google site gets loaded for you?
Is that the Australian Google site (google.com.au) or the British Google site?

Try to clear the Google cookies.

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Google: http://www.google.com/support/bin/answer.py?answer=873

more options

How do I know if I have the en-GB firefox version as I downloaded and installed it from Australia. why would it give me the GB version?

The British Google site get loaded and I do not know why when Windows 7 location os set for Australia.

more options

What is the default value of the general.useragent.locale pref if you reset that pref on the about:config page via the right-click context menu?

more options

As I outlined in my original post the general.useragent.locale has been reset to en-au and still this has made no difference.

I canot get any one to tell me how to set Firefox so that I can get search results that are relevant to my local area so it looks like I will have to remove it and use a different browser.

How can I fix this?