X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 17.0 doesn't warn me when closing multiple tabs any more

Posted

hi all

Having updated to Firefox 17.0 (from 16.0.2), for some reason I don't get warned when closing multiple tabs any more.

I've confirmed the relevant options are selected and am 100% certain this was working fine before updating Firefox today.

I've replicated the problem on my vista 32bit platform and on XP 32 bit too.

I also looked at the changelog for Firefox 17 but can't see any explanation for this change in behaviour, although I wonder whether this might have something to do with it "772319 No option to disable the "Close other tabs" prompt."

As I use Tab Mix Plus (add-on), I've also checked Firefox in safemode and have found the native tab warnings not working, so have concluded it's an issue with Firefox (rather than something to do with an extension).

I've checked "about:config" and "browser.tabs.warnOnClose" is set to true, as is "browser.tabs.warnOnCloseOtherTabs".

Any help would be appreciated.


Thanks,

Gary

hi all Having updated to Firefox 17.0 (from 16.0.2), for some reason I don't get warned when closing multiple tabs any more. I've confirmed the relevant options are selected and am 100% certain this was working fine before updating Firefox today. I've replicated the problem on my vista 32bit platform and on XP 32 bit too. I also looked at the changelog for Firefox 17 but can't see any explanation for this change in behaviour, although I wonder whether this might have something to do with it "772319 No option to disable the "Close other tabs" prompt." As I use Tab Mix Plus (add-on), I've also checked Firefox in safemode and have found the native tab warnings not working, so have concluded it's an issue with Firefox (rather than something to do with an extension). I've checked "about:config" and "browser.tabs.warnOnClose" is set to true, as is "browser.tabs.warnOnCloseOtherTabs". Any help would be appreciated. Thanks, Gary

Modified by gazzawazza

Chosen solution

weird it's finally working. so nvm i guess

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

NekoNekoMew 1 solutions 24 answers

??????????????????????

??????????????????????

Modified by NekoNekoMew

NekoNekoMew 1 solutions 24 answers

All of the follwing about:config settings are set to true: "extensions.tabmix.tabs.warnOnClose" "extensions.tabmix.protectedtabs.warnOnClose" "extensions.tabmix.warnOnclose" browser.tabs.warnOnCloseOtherTabs browser.tabs.warnOnClose

All normal settings under options are clicked it's FF17's fault

All of the follwing about:config settings are set to true: "extensions.tabmix.tabs.warnOnClose" "extensions.tabmix.protectedtabs.warnOnClose" "extensions.tabmix.warnOnclose" browser.tabs.warnOnCloseOtherTabs browser.tabs.warnOnClose All normal settings under options are clicked it's FF17's fault
FFmurphy 0 solutions 30 answers

@iamjayakumars:

Very helpful indeed, as it has been stated multiple times by gazzawazza (and me) that this setting does not have any effect in combination with Tab Mix Plus, which is the issue being discussed here.


@NekoNekoMew:

Please read more carefully what gazzawazza wrote repeatedly before, and what I already higlighted twice:

Just for your info, the about:config setting which gets locked is:

browser.warnOnQuit

As long as this setting is set to false, you won't get a warning.

@iamjayakumars: Very helpful indeed, as it has been stated '''multiple times''' by gazzawazza (and me) that this setting '''does not have any effect''' in combination with '''Tab Mix Plus''', which is the issue being discussed here. @NekoNekoMew: Please read more carefully what gazzawazza wrote repeatedly before, and what I already higlighted twice: ''Just for your info, the about:config setting which gets locked is:'' ''browser.warnOn'''Quit''''' As long as '''this '''setting is set to false, you won't get a warning.
NekoNekoMew 1 solutions 24 answers

And like I've said multiple times IK about TMP error but in my case mine is set to true and is not locked which is why I'm confused as to why I'm not getting any warnings. Isn't reading fun :3?

And like I've said multiple times IK about TMP error but in my case mine is set to true and is not locked which is why I'm confused as to why I'm not getting any warnings. Isn't reading fun :3?

Modified by NekoNekoMew

FFmurphy 0 solutions 30 answers

Post a screenshot of browser.warnOnQuit set to true while TMP is active.

"Isn't reading fun :3?"

Yes ... if you can.

Post a screenshot of '''browser.warnOnQuit''' set to true while TMP is active. ''"Isn't reading fun :3?"'' Yes ... if you can.
NekoNekoMew 1 solutions 24 answers

You were saying?

You were saying?
NekoNekoMew 1 solutions 24 answers

Anywho, like i was saying reading is fun :3

Anywho, like i was saying reading is fun :3
FFmurphy 0 solutions 30 answers

According to screenshot #1 I way saying:

"Post a screenshot of browser.warnOnQuit set to true ..."

and according to screenshot #2 I was saying:

"... while TMP is active."

According to screenshot #1 I way saying: ''"Post a screenshot of browser.warnOn'''Quit''' set to true ..."'' and according to screenshot #2 I was saying: ''"... while TMP is '''active'''."''
NekoNekoMew 1 solutions 24 answers

TMP is very much is very much active i have not once disabled it. In fact many of my tabs are protected and styled through it as well so again my statement stands.

TMP is very much is very much active i have not once disabled it. In fact many of my tabs are protected and styled through it as well so again my statement stands.

Modified by NekoNekoMew

Question owner

Hi NekoNekoMew

Please could you show what your about:config states about "browser.warnOnQuit"?

The requirement is running FF 17.0.1 and the latest version of TMP (you can use TMP 0.4.0.4.pre120724a or TMP 0.4.0.4.pre120724b).


Thanks,

Gary

Hi NekoNekoMew Please could you show what your about:config states about "browser.warnOnQuit"? The requirement is running FF 17.0.1 and the latest version of TMP (you can use TMP 0.4.0.4.pre120724a or TMP 0.4.0.4.pre120724b). Thanks, Gary
FFmurphy 0 solutions 30 answers

Today at 10:25 AM NekoNekoMew wrote:

so I'm just going to downgrade back to 16.0.2

Quite obviously this has already happened.


@gazzawazza:

He already did in screenshot #2, but guess what (see quotation above).

Today at 10:25 AM NekoNekoMew wrote: ''so I'm just going to downgrade back to 16.0.2'' Quite obviously this has already happened. @gazzawazza: He already did in screenshot #2, but guess what (see quotation above).

Modified by FFmurphy

NekoNekoMew 1 solutions 24 answers

i ALREADY HAVE. I also said that even with 0.4.0.3 and 0.4.0.3.1 on 17.0 and 17.0.1 my settings were never set to false and the warnings did show up, 2ce, but never appeared again (i don't get how they appeared but i closed Firefox and started it up 2x in a row and both times i got the warning but the third time it went back to no warnings.nothing was updated or changed b4 or after hence my confusion). The only reason I'm saying this is because TMP is not the issue it's 17.0+, whether it says true or false warnings will not show up.

i ALREADY HAVE. I also said that even with 0.4.0.3 and 0.4.0.3.1 on 17.0 and 17.0.1 my settings were never set to false and the warnings did show up, 2ce, but never appeared again (i don't get how they appeared but i closed Firefox and started it up 2x in a row and both times i got the warning but the third time it went back to no warnings.nothing was updated or changed b4 or after hence my confusion). The only reason I'm saying this is because TMP is not the issue it's 17.0+, whether it says true or false warnings will not show up.

Modified by NekoNekoMew

FFmurphy 0 solutions 30 answers

Can anyone else confirm this ...?

My confidence has slightly suffered.

Can '''''anyone else''''' confirm this ...? My confidence has slightly suffered.
NekoNekoMew 1 solutions 24 answers

please look at the other person who said they had the issue or go to the TMP website forums ty.

please look at the other person who said they had the issue or go to the TMP website forums ty.
NekoNekoMew 1 solutions 24 answers

Please note that it was tested on firefox 18+ but it only got worse so they are attempting to patch around another Mozilla screw up.

Please note that it was tested on firefox 18+ but it only got worse so they are attempting to patch around another Mozilla screw up.
NekoNekoMew 1 solutions 24 answers

To rephrase my statement having TMP activated on FF17+ cause the screw up due to faulty patches/coding on Mozilla's part and the developer can barely keep up and at this point have no intention of racing against them any longer, hence why the next full update with fix is not being released until January.

To rephrase my statement having TMP activated on FF17+ cause the screw up due to faulty patches/coding on Mozilla's part and the developer can barely keep up and at this point have no intention of racing against them any longer, hence why the next full update with fix is not being released until January.

Modified by NekoNekoMew

FFmurphy 0 solutions 30 answers

Alas, you did not understand ... again. We're all quite aware of the issue with browser.warnOnQuit having no effect when TMP is active – in fact, that's because we're all here.

But: You are the only one so far who states that he got warnings under the circumstances described above.

Furthermore, you are the only one stating "TMP is not the issue it's 17.0+".

As opposed to that, I could NOT reproduce the faulty behavior with TMP being deactivated, which clearly confirms that it's NOT an issue of FF17.

It's a bug of TMP that just shows up with Firefox versions 17.0 and above. So far for the facts ... which have been approved in the forum of TMP like gazzawazza has posted ages ago.

Please stop spamming the thread with irrelevant / aforementioned stuff.

Alas, you did not understand ... again. We're all quite aware of the issue with '''browser.warnOnQuit''' having no effect when TMP is active – in fact, that's because we're all here. But: You are the only one so far who states that he got warnings under the circumstances described above. Furthermore, you are the only one stating "TMP is not the issue it's 17.0+". As opposed to that, I could '''NOT '''reproduce the faulty behavior with TMP being ''deactivated'', which clearly confirms that it's '''NOT '''an issue of FF17. It's a bug of TMP that just shows up with Firefox versions 17.0 and above. So far for the facts ... which have been approved in the forum of TMP like gazzawazza has posted ages ago. '''Please stop spamming the thread with irrelevant / aforementioned stuff.'''

Modified by FFmurphy

NekoNekoMew 1 solutions 24 answers

Then don't continually ask the same question.

Then don't continually ask the same question.
FFmurphy 0 solutions 30 answers

Which was ...?

Which was ...?
NekoNekoMew 1 solutions 24 answers

everyone giving their opinion on what i must obviously be overlooking even though i stated many times that everything is set to true.

everyone giving their opinion on what i must obviously be overlooking even though i stated many times that everything is set to true.

Modified by NekoNekoMew