X
Tap here to go to the mobile version of the site.

Support Forum

javascript "Permission to read file was denied"

Posted

Did a manual "About Firefox" update. Typed in system pwd after download, clicked Force Quit All, Firefox hung. Had to Force Quit Firefox. Restarted, and I get a "Javascript Application Permission to read file was denied." every time Firefox starts. Nothing in error console.

Did a manual "About Firefox" update. Typed in system pwd after download, clicked Force Quit All, Firefox hung. Had to Force Quit Firefox. Restarted, and I get a "Javascript Application Permission to read file was denied." every time Firefox starts. Nothing in error console.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • LogMeIn remote control components
  • 5.1.10411.0
  • WebEx64 General Plugin Container Version 202
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Web Player version 2.0.2.39
  • Garmin Communicator Plug-in Version 2.9.2.0
  • RealPlayer Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Firebug
1.10.6
true
firebug@software.joehewitt.com
Greasemonkey
1.5
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
infoRSS
1.4.1
true
{f65bf62a-5ffc-4317-9612-38907a779583}
New Tab Homepage
0.4.3
true
{66E978CD-981F-47DF-AC42-E3CF417C1467}
Page Speed
1.12.9.1
true
{e3f6c2cc-d8db-498c-af6c-499fb211db97}
URL Shrink Easy
0.46
true
tkuse@telekawaru.com
Xmarks
4.1.3
true
foxmarks@kei.com
RankChecker
1.8.21
false
rankchecker@seobook.com
SEO For Firefox
3.6.7
false
seo4firefox@seobook.com
Seo Toolbar
1.2.1
false
seotoolbar@seobook.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.warnOnClose
false
browser.zoom.full
false
dom.max_chrome_script_run_time
0
dom.report_all_js_exceptions
true
extensions.lastAppVersion
17.0
font.size.variable.x-western
15
gfx.blacklist.webgl.msaa
4
network.cookie.prefsMigrated
true
network.http.max-connections
40
network.http.max-connections-per-server
16
network.http.max-persistent-connections-per-proxy
12
network.http.pipelining.maxrequests
6
places.database.lastMaintenance
1352746815
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
places.last_vacuum
1305095547
plugin.disable_full_page_plugin_for_types
print.macosx.pagesetup
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUgQ29tcHV0ZXIvL0RURCBQTElT…
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_footercenter
&PT
print.print_footerleft
print.print_footerright
print.print_headerleft
print.print_headerright
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size
0
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.cpd.cookies
false
privacy.cpd.formdata
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.URL
security.OCSP.signingCA
Builtin Object Token:IPS CLASE1 root
security.disable_button.openCertManager
false
security.warn_entering_weak.show_once
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Graphics
Vendor ID
0x10de
Device ID
0x 609
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 8800 GS OpenGL Engine -- 2.1 NVIDIA-1.6.36
GPU Accelerated Windows
1/1 OpenGL
AzureCanvasBackend
quartz
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158985 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Helpful Reply

Started in Safe Mode, Default Theme (only one installed) - no error. Restarted with all plugins disabled, error. Restarted with no HW acceleration, error. Restarted with all extensions disabled, no error. Elimination finds that infoRSS 1.4.1 causes the error. It is the latest version. Anything else I can do? How can I find out which file is causing the actual error?

Started in Safe Mode, Default Theme (only one installed) - no error. Restarted with all plugins disabled, error. Restarted with no HW acceleration, error. Restarted with all extensions disabled, no error. Elimination finds that infoRSS 1.4.1 causes the error. It is the latest version. Anything else I can do? How can I find out which file is causing the actual error?
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158985 answers

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

Try to create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Really? I've already narrowed it down to one specific extension, and I have 8+ years in this profile. Is there another way to explore errors/files for just infoRSS?

Really? I've already narrowed it down to one specific extension, and I have 8+ years in this profile. Is there another way to explore errors/files for just infoRSS?
Grandpa Can Fix Anything 0 solutions 13 answers

I'm running into this same problem beginning with FF 17.0 and 17.0.1. However, it happens only when FF starts on my iGoogle home page. If FF opens on another page, I do not get this message. If I go back to FF 16.0.2, I do not get this Javascript message.

I have not yet tried testing these various suggested solutions yet. I'll try a few and report back. I, too, do not want to have to rebuild my profile yet again.

I'm running into this same problem beginning with FF 17.0 and 17.0.1. However, it happens only when FF starts on my iGoogle home page. If FF opens on another page, I do not get this message. If I go back to FF 16.0.2, I do not get this Javascript message. I have not yet tried testing these various suggested solutions yet. I'll try a few and report back. I, too, do not want to have to rebuild my profile yet again.

Modified by Grandpa Can Fix Anything

Grandpa Can Fix Anything 0 solutions 13 answers

Bingo! After I disabled infoRSS and restarted FF 17.0.1, the Javascript message did not appear. When I enabled infoRSS and restarted FF, the message reappeared. So the culprit would seem to be infoRSS -- or infoRSS in combination with some other add-on or plug-in that andrewm57 both use.

I realize that the javascript error occurs only my homepage that has the infoRSS feed running. So I think that infoRSS and FireFox 17 alone are causing this problem. In addition, when I open the "Options" for inforRSS within Add-On Manager, i got the same javascript message three times before it stopped appearing.

If you think it would help andrewm57, I can use Infolister to create a list of my add-ons and plug-ins to post here for you to compare with the ones you use. Perhaps we can narrow this down.

It seems highly unlikely that we both have corrupt profiles. My best guess is that infoRSS or inforRSS in combination with another add-on or plug-in is the cause of this problem.

I have written to inforss@mozdev.org to see if the folks there might know what is causing this behavior in FF 17 and can suggest a solution.

Bingo! After I disabled infoRSS and restarted FF 17.0.1, the Javascript message did not appear. When I enabled infoRSS and restarted FF, the message reappeared. So the culprit would seem to be infoRSS -- or infoRSS in combination with some other add-on or plug-in that andrewm57 both use. I realize that the javascript error occurs only my homepage that has the infoRSS feed running. So I think that infoRSS and FireFox 17 alone are causing this problem. In addition, when I open the "Options" for inforRSS within Add-On Manager, i got the same javascript message three times before it stopped appearing. If you think it would help andrewm57, I can use Infolister to create a list of my add-ons and plug-ins to post here for you to compare with the ones you use. Perhaps we can narrow this down. It seems highly unlikely that we both have corrupt profiles. My best guess is that infoRSS or inforRSS in combination with another add-on or plug-in is the cause of this problem. I have written to inforss@mozdev.org to see if the folks there might know what is causing this behavior in FF 17 and can suggest a solution.

Modified by Grandpa Can Fix Anything

Helpful Reply

I've already found it's just infoRSS alone, and it's being tracked at MozDev: https://www.mozdev.org/bugs/show_bug.cgi?id=25227

Adding your details there may help escalate a fix.

I've already found it's just infoRSS alone, and it's being tracked at MozDev: https://www.mozdev.org/bugs/show_bug.cgi?id=25227 Adding your details there may help escalate a fix.
Grandpa Can Fix Anything 0 solutions 13 answers

Solved! Didier Ernotte (who I think is one of the creators of infoRSS) has kindly checked into this and identified the problem. He wrote to me:

"It appears that mozilla has changed the internal API for security. The "netscape.security.PrivilegeManager.enablePrivilege" is no longer valid, but no longer required as well, and a call to this method generate an exception. "I will fix that and submit the version to mozilla addons site, but it could take them some time to validate the submission. In the meantime, If you know where the javascript files are located, you can comment out every line containing "netscape.security.PrivilegeManager.enablePrivilege"."

So if anybody here knows where the Javascript files are normally kept, please share that with us so we can comment out those lines. Otherwise, a new version of infoRSS should be available in the not too distant future.

Thank you to Didier Ernotte for solving this problem.

Solved! Didier Ernotte (who I think is one of the creators of infoRSS) has kindly checked into this and identified the problem. He wrote to me: "It appears that mozilla has changed the internal API for security. The "netscape.security.PrivilegeManager.enablePrivilege" is no longer valid, but no longer required as well, and a call to this method generate an exception. "I will fix that and submit the version to mozilla addons site, but it could take them some time to validate the submission. In the meantime, If you know where the javascript files are located, you can comment out every line containing "netscape.security.PrivilegeManager.enablePrivilege"." So if anybody here knows where the Javascript files are normally kept, please share that with us so we can comment out those lines. Otherwise, a new version of infoRSS should be available in the not too distant future. Thank you to Didier Ernotte for solving this problem.
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158985 answers

That should be done in the infoRSS files in the extensions folder in the Firefox Profile Folder.

From https://www.mozdev.org/bugs/show_bug.cgi?id=25227#c5

  1. Open your profile folder

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
  1. Find the inforss.jar file

Go to the extensions folder and find the InfoRSS extensions folder:

  • {f65bf62a-5ffc-4317-9612-38907a779583}

The inforss.jar file is a ZIP archive, so you need to access the files via an archive manager.
Best is to use an archive manager that allows to edit files directly in the archive without the need to unpack the archive (most will allow this).

  1. Open this and comment out all lines in all files that call enablePrivilege by adding // in front of the lines
    (content > inforss > [inforss.js, inforssIO.js, inforssOption.js,inforssRDFRepository.js])
  2. Save the changes to the jar file and restart FF
That should be done in the infoRSS files in the extensions folder in the Firefox Profile Folder. From https://www.mozdev.org/bugs/show_bug.cgi?id=25227#c5 # Open your profile folder You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder # Find the inforss.jar file Go to the extensions folder and find the InfoRSS extensions folder: *{f65bf62a-5ffc-4317-9612-38907a779583} The inforss.jar file is a ZIP archive, so you need to access the files via an archive manager.<br /> Best is to use an archive manager that allows to edit files directly in the archive without the need to unpack the archive (most will allow this). # Open this and comment out all lines in all files that call enablePrivilege by adding // in front of the lines<br />(content > inforss > [inforss.js, inforssIO.js, inforssOption.js,inforssRDFRepository.js]) # Save the changes to the jar file and restart FF