X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Reset "about:home" search engine?

Posted

When I search from the home page it used to give me Google results, but that somehow got changed by AVG Anti Virus and now it goes to an AVG Safe Search results page. I've since switched to a different anti virus and completely uninstalled AVG, including any Add-Ons I could find. I've scoured the "about:config" page for anything related to AVG. I did find a few elements that seemed related, but resetting them to default hasn't changed anything. Any help would be appreciated.

Chosen solution

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Pando Web Plugin
  • VLC media player Web Plugin 2.0.2
  • Picasa plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 4.1.10329.0
  • GEPlugin
  • Unity Player 3.2.0f4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • npdnupdater2
  • npdnu

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

Great Sin, thank you! It worked! I would never have found that element.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You're welcome.

babasime 0 solutions 1 answers

did that, after i restart the setting turned back to "user set".

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Do you have a mozilla.cfg file in the Firefox program folder?

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

If you do not keep changes after a restart then see:

Question owner

I shouldn't be allowed near torrents when I'm drunk... Now when I try to search from the home page, it doesn't search. I can type in something to search for and click the "search" button or press "Enter" and nothing happens. I expect this is another about:config element, but I haven't the first clue what it would be called.