X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Lags Like Hell with Flash

Posted

Ok, here's the deal.

After long use Firefox starts to lag like crazy with Flash. And... It doesn't seem to be a problem with Flash. It's more likely that the browser itself what is causing the issue.

After I use Firefox for some time Flash starts lagging badly. BUT! This happens only if I have my Firefox window active. If I open the Task Manager on top of Firefox window, Flash stops lagging as if Harry Porter himself cast a spell with his magic stick making everything work like a charm.

I made a small video showcasing the bug: https://www.dropbox.com/s/l2c5pbn1xwy58dc/12-11-2012%2019-07-15.avi

- The bug still appears even in Safe Mode (all addons disabled).

- With hardware acceleration disabled in Flash bug still remains.

- With Chrome and other browsers everything works fine.

- The bug will go away after restart - and then will start to appear after Firefox is in use for some time.

- Normally it re-appears after I close my laptop's lid forcing it to go to sleep mode. After it wakes up - the bug is there.

- There was no such a bug in the past - it started to appear as new Firefox versions were released - don't know the exact version but I assume it all started from version 14 or 15.

Any thoughts?

Modified by Domov1k

Chosen solution

> disable protected mode in Flash 11.3 and later

Seems like that helped. Thanks!

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox stays opened for too long.

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • NPGameWebStarter
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Helpful Reply

Did you try to disable protected mode in the Flash plugin?

Also make sure that you allow the plugin-container process in the firewall.

You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
  • downgrade the Flash player to version 10.3 or 11.2

Chosen Solution

> disable protected mode in Flash 11.3 and later

Seems like that helped. Thanks!

Fudd12345 0 solutions 2 answers

Disabling the flash protected mode was not helpful after all. I will keep trying.

Modified by Fudd12345