X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox suddenly stopped allowing access to Https sites, saying the sites are untrusted. Chrome and ie allow them. What's up?

Posted

Windows 7 64 bit ESET antivirus The sites in question are all sites that I've used frequently, they are trusted. When I read the details on the warning page at least one site had a valid certificate based on the dates. The reasons given are not all "expired" there are several others. Here's another example: www.bankofamerica.com uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)

Chosen solution

Thanks for pointing me in the right direction. With your help I was able to correct the problem.

Read this answer in context 0

Additional System Details

Sites Affected

https://discover.com among others

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Some examples are ESET and Bitdefender.

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol

\*BitDefender -> Privacy settings -> disable Scan SSL

Chosen Solution

Thanks for pointing me in the right direction. With your help I was able to correct the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You're welcome