Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox does not show images or play videos

  • 12 replies
  • 11 have this problem
  • 4049 views
  • Last reply by cor-el

more options

i've FF 16.0.2 on 2 PCs - one will not show images in certain sites (IMDb, justdial.com) but they will be shown in IE. FF in other PC will not play videos (youtube) but will show images. i have Win 7 HPx64. i tried downgrading flash player from 11.3 to 10 with no resolution. 'load images automatically' is checked in options-->content. i have VLC web plugin 2.0.2.0.

Chosen solution

Do any of the missing images show up in Tools > Page Info > Media ?

Did you try Safe mode?

Note that extensions like Adblock Plus continually update their filters and it is quite possible that content gets blocked by a too general filter rule.

Read this answer in context 👍 1

All Replies (12)

more options

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.


If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

See also:

more options

this seems an automated/ready-to-serve reply

none of the images or videos are blocked by adblock/noscript which i use as addons. all suggested options are in place.

more options

Did you check the Tools > Page Info > Media tab to make sure that images weren't blocked?

Are you using Adblock Plus on any of the computers?

You can create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Note that "Reset" creates a new default profile with a time stamp appended to identify it and tries to recover settings like bookmarks and history and passwords and cookies and auto-fill data from the old profile, but you lose data like extensions and other customizations.

Firefox 15+ versions will move the old profile folder to an "Old Firefox Data-##" folder on the Desktop that gets a number appended if you use reset more than once.

You can recover more data from the old profile, but be cautious.

more options

where's Tools > Page info? FF 16.0 has 'Options'.

been using Adblock past 3-4 yr without issue. sometimes if i Uninstall > Reinstall FF,with all the extns incl Adblock Plus, the issue resolves (did that a coupla times in the past) - but i don't want to do that now as it's a hassle to customize my FF browser all over again.

creating a new profile and tfring old profile files seems a hassle.

if all fails, plan to uninstall/reinstall FF as a last resort.

more options

You can press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden to access the Tools menu.

more options

thanks cor-el. i checked 'page info > media' and images are not blocked

more options

Chosen Solution

Do any of the missing images show up in Tools > Page Info > Media ?

Did you try Safe mode?

Note that extensions like Adblock Plus continually update their filters and it is quite possible that content gets blocked by a too general filter rule.

Modified by cor-el

more options

thanks. disabling Adblock Plus did the trick.

btw, any other non-problematic addon to block pesky ads/flash

more options

Hi all, I am experiencing the same problem here. I have not installed any of the Adblock Plus or NoScript or Flash Block add-ons. Now, images are blocked after a while using ff. I found that by clearing the cashe ( Options -> Advanced -> Network -> Cashed Web Contend -> Clear Now) the problem is temporary solved (until cashed web content reach 25+MB)

Any ideas?

more options

the 'disable automatic cache management' option is unchecked in my 'network' options you've mentioned and i don't face any problem like yours. you can try leaving this option unchecked and see.

more options

Thank you for the answer drapatil, Unfortunately, that is not the case. I had it unchecked and I have also tried it checked with several values in the limit cashe...

more options

Do you see those images in Tools > Page Info > Media ?

Did you try Safe mode?