X
Tap here to go to the mobile version of the site.

Support Forum

firefox does not show images or play videos

Posted

i've FF 16.0.2 on 2 PCs - one will not show images in certain sites (IMDb, justdial.com) but they will be shown in IE. FF in other PC will not play videos (youtube) but will show images. i have Win 7 HPx64. i tried downgrading flash player from 11.3 to 10 with no resolution. 'load images automatically' is checked in options-->content. i have VLC web plugin 2.0.2.0.

i've FF 16.0.2 on 2 PCs - one will not show images in certain sites (IMDb, justdial.com) but they will be shown in IE. FF in other PC will not play videos (youtube) but will show images. i have Win 7 HPx64. i tried downgrading flash player from 11.3 to 10 with no resolution. 'load images automatically' is checked in options-->content. i have VLC web plugin 2.0.2.0.

Chosen solution

Do any of the missing images show up in Tools > Page Info > Media ?

Did you try Safe mode?

Note that extensions like Adblock Plus continually update their filters and it is quite possible that content gets blocked by a too general filter rule.

Read this answer in context 1

Additional System Details

This happened

A few times a week

This started when...

after updating to 16.0

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Nokia Suite Enabler Plugin
  • VLC media player Web Plugin 2.0.2
  • 4.1.10329.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Application Basics
Name
Firefox
Version
16.0.2
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
BetterPrivacy
1.68
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
FastestFox
5.0.2
true
smarterwiki@wikiatic.com
FlashGot
1.4.8.5
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
IE Tab +
2.04.20110724
true
coralietab@mozdev.org
KeyScrambler
2.9.3.0
true
keyscrambler@qfx.software.corporation
LastPass
2.0.0
true
support@lastpass.com
NetVideoHunter
1.9.5
true
netvideohunter@netvideohunter.com
Norton Vulnerability Protection
11.1.1.5 - 2
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
NoScript
2.5.9
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Speed Dial
0.9.6.10
true
{64161300-e22b-11db-8314-0800200c9a66}
Xmarks
4.1.3
true
foxmarks@kei.com
DigitalPersona Extension
5.0.0.4490
false
otis@digitalpersona.com
Norton Toolbar
2013.2.0.18
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage
chrome://speeddial/content/speeddial.xul
browser.startup.homepage_override.buildID
20121024073032
browser.startup.homepage_override.mstone
16.0.2
extensions.lastAppVersion
16.0.2
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1351185195
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Mobility Radeon HD 5650
Vendor ID
0x1002
Device ID
0x68c1
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.771.1.0
Driver Date
9-9-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Mobility Radeon HD 5650 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
13076 solutions 119707 answers

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.


If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

See also:

If you use extensions (Tools > Add-ons > Extensions) like <i>Adblock Plus</i> or <i>NoScript</i> or <i>Flash Block</i> that can block content then make sure that such extensions aren't blocking content. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- If images are missing then check that you aren't blocking images from some domains. *Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions" *Check that images are enabled: Tools > Options > Content: [X] Load images automatically *Check the exceptions in "Tools > Options > Content: Load Images > Exceptions" *Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key). If an image in the list is grayed and there is a check-mark in the box "<i>Block Images from...</i>" then remove that mark to unblock the images from that domain. Make sure that you do not block third-party images, the permissions.default.image pref should be 1. There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *http://kb.mozillazine.org/Images_or_animations_do_not_load

Question owner

this seems an automated/ready-to-serve reply

none of the images or videos are blocked by adblock/noscript which i use as addons. all suggested options are in place.

this seems an automated/ready-to-serve reply none of the images or videos are blocked by adblock/noscript which i use as addons. all suggested options are in place.
cor-el
  • Top 10 Contributor
  • Moderator
13076 solutions 119707 answers

Did you check the Tools > Page Info > Media tab to make sure that images weren't blocked?

Are you using Adblock Plus on any of the computers?

You can create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Note that "Reset" creates a new default profile with a time stamp appended to identify it and tries to recover settings like bookmarks and history and passwords and cookies and auto-fill data from the old profile, but you lose data like extensions and other customizations.

Firefox 15+ versions will move the old profile folder to an "Old Firefox Data-##" folder on the Desktop that gets a number appended if you use reset more than once.

You can recover more data from the old profile, but be cautious.

Did you check the Tools > Page Info > Media tab to make sure that images weren't blocked? Are you using Adblock Plus on any of the computers? You can create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files. See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems Note that "Reset" creates a new default profile with a time stamp appended to identify it and tries to recover settings like bookmarks and history and passwords and cookies and auto-fill data from the old profile, but you lose data like extensions and other customizations. *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox 15+ versions will move the old profile folder to an "Old Firefox Data-##" folder on the Desktop that gets a number appended if you use reset more than once. You can recover more data from the old profile, but be cautious. *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile

Question owner

where's Tools > Page info? FF 16.0 has 'Options'.

been using Adblock past 3-4 yr without issue. sometimes if i Uninstall > Reinstall FF,with all the extns incl Adblock Plus, the issue resolves (did that a coupla times in the past) - but i don't want to do that now as it's a hassle to customize my FF browser all over again.

creating a new profile and tfring old profile files seems a hassle.

if all fails, plan to uninstall/reinstall FF as a last resort.

where's Tools > Page info? FF 16.0 has 'Options'. been using Adblock past 3-4 yr without issue. sometimes if i Uninstall > Reinstall FF,with all the extns incl Adblock Plus, the issue resolves (did that a coupla times in the past) - but i don't want to do that now as it's a hassle to customize my FF browser all over again. creating a new profile and tfring old profile files seems a hassle. if all fails, plan to uninstall/reinstall FF as a last resort.
cor-el
  • Top 10 Contributor
  • Moderator
13076 solutions 119707 answers

You can press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden to access the Tools menu.

You can press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden to access the Tools menu.

Question owner

thanks cor-el. i checked 'page info > media' and images are not blocked

thanks cor-el. i checked 'page info > media' and images are not blocked
cor-el
  • Top 10 Contributor
  • Moderator
13076 solutions 119707 answers

Chosen Solution

Do any of the missing images show up in Tools > Page Info > Media ?

Did you try Safe mode?

Note that extensions like Adblock Plus continually update their filters and it is quite possible that content gets blocked by a too general filter rule.

Do any of the missing images show up in Tools > Page Info > Media ? Did you try Safe mode? Note that extensions like Adblock Plus continually update their filters and it is quite possible that content gets blocked by a too general filter rule.

Modified by cor-el

Question owner

thanks. disabling Adblock Plus did the trick.

btw, any other non-problematic addon to block pesky ads/flash

thanks. disabling Adblock Plus did the trick. btw, any other non-problematic addon to block pesky ads/flash
celetron 0 solutions 2 answers

Hi all, I am experiencing the same problem here. I have not installed any of the Adblock Plus or NoScript or Flash Block add-ons. Now, images are blocked after a while using ff. I found that by clearing the cashe ( Options -> Advanced -> Network -> Cashed Web Contend -> Clear Now) the problem is temporary solved (until cashed web content reach 25+MB)

Any ideas?

Hi all, I am experiencing the same problem here. I have not installed any of the Adblock Plus or NoScript or Flash Block add-ons. Now, images are blocked after a while using ff. I found that by clearing the cashe ( Options -> Advanced -> Network -> Cashed Web Contend -> Clear Now) the problem is temporary solved (until cashed web content reach 25+MB) Any ideas?

Question owner

the 'disable automatic cache management' option is unchecked in my 'network' options you've mentioned and i don't face any problem like yours. you can try leaving this option unchecked and see.

the 'disable automatic cache management' option is unchecked in my 'network' options you've mentioned and i don't face any problem like yours. you can try leaving this option unchecked and see.
celetron 0 solutions 2 answers

Thank you for the answer drapatil, Unfortunately, that is not the case. I had it unchecked and I have also tried it checked with several values in the limit cashe...

Thank you for the answer drapatil, Unfortunately, that is not the case. I had it unchecked and I have also tried it checked with several values in the limit cashe...
cor-el
  • Top 10 Contributor
  • Moderator
13076 solutions 119707 answers

Do you see those images in Tools > Page Info > Media ?

Did you try Safe mode?

Do you see those images in Tools > Page Info > Media ? Did you try Safe mode? *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes