X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

DL FF 16.0.1 ATTEMPTED INSTALL OVER 9.01 ERROR MSG CANOT INSTALL REQ WIN XP SP2 OR LTR I'M USING XP SP3 ?

Posted

Was using FF 15 and had a disk crash so installed a bu disk and it had 9.0.1 installed. After continuously getting the annoying ff pop up windows I decided to update to 16.0.1 - Downloaded and saved the firefox setup 16.0.1 - exited FF and dbl clicked on the install file. It started to extract the archived files and then I get a setup error message:

Sorry Firefox can't be installed. This version of Firefox requires Microsoft Windows xp sp 2 or later

I am using Windows XP professional 2002 w SP3

I installed it as an upgrade from Windows 2000 Professional

On my other drive the one that crashed I had installed FF from 4 or 5 up to 15.01 without any problem and this drive was an exact copy using maxblast software of that drive it except it was a few months old hence only up to ff 9.01

Additional System Details

Installed Plug-ins

  • Google Update
  • Musicnotes Viewer plugin 1.19.0 For more information visit www.musicnotes.com
  • Shockwave Flash 11.0 r1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • npdivxplayerplugin
  • DivX Web Player version 1.4.3.4

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

Can you confirm that if you go to windows update and install every update there you can install Firefox? Also, are you downloading Firefox from www.getfirefox.com

Question owner

I downloaded ff 16.0.1 from http://www.mozilla.org/en-US/firefox/

I just turned auto update back on and installed all 52 of them. Rebooted and attempted to install FF 16.0.1 same thing as soon as it extracts the files I get the same error message. Cannot install because this version requires Windows XP SP 2 OR ABOVE.

Does anyone know what the installation program matches on to determine what OS is installed and whether it is xp sp2 or above???

I'm sure there are numerous variables involved that could cause this problem. I would imagine that if Mozilla was getting feedback from others who have Windows xp sp3 installed and were getting a similar error message then it is very likely a bug in this latest ff release. If the problem is unique to me than probably the difficulty is local and there is some eccentricity in the way my OS was installed. I upgrated my Windows 2000 Professioinal to XP pro with sp3 integrated.

My installed OS as reported by SYSTEM PROPERTIES > GENERAL TAB is:

Microsoft Windows XP Professional Version 2002 SP 3

My CD is Microsoft Windows XP Professional SP3 BIE INTEGRATED MAR 2011

Although the PC I am using only has FF 9.0.1 the Hard Drive or the C (active) partition is an exact duplicate of the HD on my other PC that just crashed. This duplication of my active partition was made 5 or 6 months ago or thereabouts. The drive that crashed was more current and had been updated to FF 15.0.1 and had no difficulties with all the updates on that drive from 9 to 15.

I'm trying to find my setup file for (15.0.1) to see if I can install it or will also check the Mozilla site to see if older versions are available for download.