X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Facebook and other websites not loading properly in Firefox (Solution)

Posted

This is for anyone who has had issues loading Facebook, eBay, twitter or any other site which shows plain text pushed to the left hand-side of the screen and fails to load images.

This issue had me stumped for about 3 hours. No matter what I did. No matter what I disabled. The problem remained. I cleared my cache, reset cookies, disabled addons, reset Firefox to default settings and kicked my pc a few times for good measure.

The problem was fairly simple and at my end, this is not a problem with firefox. SSL certification for facebook was being deemed invalid and therefore the site failed to load properly. Now because Firefox doesn't deal with SSL certificate failures, there had to be something else going on in another program. I then realised that Kaspersky Internet Security 2013 was the problem. If a website failed SSL certification for any reason Kaspersky Blocks access to the site which was causing the page to not load properly. You have to disable Kaspersky's SSL certifcation checks to be able to run the websites properly. You need to load your Kaspersky main menu and click Settings once there go to the tab that looks like a cardboard box (Object Detection Settings and Exclusion Rules) then when you can see a list of different options select Network and you should see Monitored Ports and Encrypted Connections Scan, disabled the encrypted connections then reload Firefox and try the webpage that wouldn't load. To know that kaspersky is the problem, you will get a dialogue saying you have to add facebook as an exception since it failed SSL Certification and this was the culprit for me atleast.

I looked at the mozilla support forums and it seemed to me, many people were getting this issue and some issues went completely unresolved and there was no mention about Kaspersky, so I hope this helps.bold text

Additional System Details

Sites Affected

http://www.facebook.com

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Plug-in for detecting Nero Kwik Media.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

Helpful Reply

Hi Hindhaughlee,
Thanks for the post.

This may not be the best place to post such a solution but maybe some users will find it. If it turns out to be a major problem with a simple solution maybe we will manage to document it somewhere.

Are you able to provide more details please:

  • exactly what software and software versions is the problem with ?
    You appear to be a Windows 8 user, but presumably the Kaspersky software may be applicable to other Windows versions, which Kaspersky software is this tested with ?
  • What is he exact error message or warning that Kaspersky generates in this situation ?
  • is the problem documented elsewhere, preferably in a public open site, if so maybe you could provide a link
  • can you detail simple but exact detailed Steps To Reproduce that will enable others to test out this problem and solution.

Cheers

John
One of the forum moderators J99


P.S.
Anyone with this problem finding that the solution works may wish to vote for this thread and solution. Or if someone else can produce links to examples of this or you are able to give precise Steps To Reproduce please add a post of your own.

Modified by John99

eternamicizia 0 solutions 1 answers

Helpful Reply

Hi, I also have this problem where the sites don't load properly, but I do not have Kaspersky, so I think the culprit may be someplace else. Thank you in advance for your help.

Windows Vista Home Premium SP2 Firefox 16.0.1

Modified by eternamicizia

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

Hi eternamicizia,

Probably best if you start your own thread using /questions/new (post back here if you do so,and we can cross reference the threads).

If it is a one off or intermittent problem try clearing cookies and cache. For facebook check you are not in an HTML5 trial. For general Flash problems if using Windows >= Vista consider disabling Adobe's protected mode. If you start a new thread your own problems may be investigated.

jasoncliff 0 solutions 2 answers

Java does work if you start your browser from the start menu including if it is pinned to the start bar. If you use a shortcut from the desktop everything works great.

I had this problem for over a month before I finally found the solution and cannot even begin to understand why Windows 8 has such a major flaw.

Serbia 0 solutions 1 answers

I seem to be having the same problem. I've tried opening Firefox from a shortcut, and still have the same issue. I'm using Firefox 19.0.2 and using Windows 8. I've tried resetting Firefox and clearing the cache. I'm having this trouble with many websites, particularly facebook and espn.com. I'm not a very knowledgeable user, so if anyone would be able to walk me through a solution, I'd be grateful.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

Everyone.

Read this thread but if you have a continuing problem yourself please start your own question


Serbia,

It would be better if you started your own thread by asking a question

  1. use /questions/new
  2. try to follow the prompts to add troubleshooting information
  3. explain your problem as best you can.
    Are you having difficulty accessing websites
    Or are you seeing text on one side only
  4. say what security related and any adware blocking software is in use
  5. you may wish to post back in this thread once you have asked your own question. Readers of this thread will be able to find your question.

See Also

Modified by John99

carlos74923 0 solutions 1 answers

its all about the cookies ppl ., go into firefox options go into your privacy tab then scroll down click on remove individual cookies then remove facebook then restart and you good ,. that wrked for me