X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot open url links in Firefox. Tried a reset to factory settings, and also tried Firefox Safe Mode start. Neither helped. Clicking on same links in Safari ok

Posted

On a 13" MacBook. Also tried Firefox-Preferences-Applications. No help. Also trying same with Google Chrome work fine - so websites are not problem. New tab opens, but is blank. Thanks in advance for any help. TDS

Chosen solution

Try to disable the Adobe Reader plugin in Firefox (Tools > Add-ons > Plugins) and use the external Adobe Reader application or Preview application instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

PDF files may also be found under another entry like Portable document.


Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Not sure. Probably after upgrade of Firefox.

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • Logitech Harmony Browser Plug-In 1.2.0.1
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.4
  • 5.1.10411.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • RealPlayer Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Question owner

Forgot to mention that same happens with PDF files - they also open blank tab (used to open just fine). I did try the recommended Preferences - General - Applications and reset all PDF actions to "Always Ask". By the way, nothing is asked of me now that I have done it, and it still opens blank tab. TDS

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

Try to disable the Adobe Reader plugin in Firefox (Tools > Add-ons > Plugins) and use the external Adobe Reader application or Preview application instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

PDF files may also be found under another entry like Portable document.


Question owner

Cor-el - thanks for the information - that did, indeed, fix my problem. Have a great one! TDS