Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 15 reporting EVERY site as not trusted

  • 11 replies
  • 14 have this problem
  • 11703 views
  • Last reply by cor-el

more options

This Connection is Untrusted

         You have asked Firefox to connect

securely to www.mozilla.org, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

This happens for every site I go to http https edu/com/net/org. I add exceptions and I can get around on a site for a few hour, then I have to re-add exceptions even for mozilla.org

Chosen solution

please try to go to firefox > help > troubleshooting information > profile folder - show folder & delete or rename the file cert8.db in the window that is opening. afterwards restart the browser (this will regenerate the file in question again).

is the problem still persisting after this step? if so please try going to https://support.mozilla.org once again, select "i understand the risks" on the error page & "add exception...". when you click the "view..." button on the opening dialog, which information is provided at the "Issued by" section of this certificate? thanks

Read this answer in context 👍 3

All Replies (11)

more options

hello koncrete, what kind of error code is shown in the technical details section of the error page?

more options

I just grabbed the first one I can find

accounts.google.com uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)

more options

Here is the one I just got from refreshing this page

support.mozilla.org uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)

more options

ok & what kind of security software are you currently using? (in the past i've seen some simliar issues when scanning of ssl encrypted network traffic was enabled in such programs)

more options

Enterprise McAfee 8.8 build 5400.1158 DAT 6861.0000

I am not 100% what proxy/firewall combo is being used but I do know that other people with the same config as me can use FF just fine on this network.

I have tried the reset FF option and still get this.

more options

Chosen Solution

please try to go to firefox > help > troubleshooting information > profile folder - show folder & delete or rename the file cert8.db in the window that is opening. afterwards restart the browser (this will regenerate the file in question again).

is the problem still persisting after this step? if so please try going to https://support.mozilla.org once again, select "i understand the risks" on the error page & "add exception...". when you click the "view..." button on the opening dialog, which information is provided at the "Issued by" section of this certificate? thanks

more options

Done, I'll report back if this is indeed the fix, if so your freaking awesome

more options

Some security software intercept secure connections and send their own certificate.

Some examples are ESET and Bitdefender.

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
  • BitDefender -> Privacy settings -> disable Scan SSL

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

more options

Madperson you did indeed fix it... Thank you very much, you have made a lot of my job easier on me!!!

more options

@cor-el: Thank you soooo much! You save my all day! After disable scan SSL in - my case - BitDefender settings Firefox start working properly with https addresses. :-)

more options

You're welcome