X
Tap here to go to the mobile version of the site.

Support Forum

How do I manage Firefox fullscreen permissions on HTML5 videos?

Posted

I accidentally set youtube's HTML5 player to disable full screen - how do I re-enable it or manage my permissions for HTML 5 full screen video?

I accidentally set youtube's HTML5 player to disable full screen - how do I re-enable it or manage my permissions for HTML 5 full screen video?

Chosen solution

That appears to be stored as a permission.

You can open the about:permissions page via the location bar and select www.youtube.com in the left pane.
You will notice a full screen select with three choices and with Block currently selected.
You can set it to Allow or to Always Ask as you like.

Also accessible via Tools > Page Info > Permissions


Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.21
  • Version 3.8.1.9672
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17576 solutions 158991 answers

Try to clear the YouTube cookies

  • Tools > Options > Privacy > Cookies: "Show Cookies"

YouTube may also be using local storage to store data.

I have this 'cookie' in local storage to set the volume level:

yt-player-volume: {"volume":100,"nonNormalized":null,"muted":false}

You can delete the webappsstore.sqlite file in the Firefox Profile Folder to clear all data in local (DOM) storage.

See also "Storage location and clearing the data":

Try to clear the YouTube cookies *Tools > Options > Privacy > Cookies: "Show Cookies" YouTube may also be using local storage to store data. I have this 'cookie' in local storage to set the volume level: <pre><nowiki>yt-player-volume: {"volume":100,"nonNormalized":null,"muted":false}</nowiki></pre> You can delete the webappsstore.sqlite file in the Firefox Profile Folder to clear all data in local (DOM) storage. See also "Storage location and clearing the data": *https://developer.mozilla.org/en/dom/storage

Question owner

Neither option works, unfortunately. Have already tried clearing cookies before resorting to the forum.

Neither option works, unfortunately. Have already tried clearing cookies before resorting to the forum.
cor-el
  • Top 10 Contributor
  • Moderator
17576 solutions 158991 answers

Chosen Solution

That appears to be stored as a permission.

You can open the about:permissions page via the location bar and select www.youtube.com in the left pane.
You will notice a full screen select with three choices and with Block currently selected.
You can set it to Allow or to Always Ask as you like.

Also accessible via Tools > Page Info > Permissions


That appears to be stored as a permission. You can open the about:permissions page via the location bar and select www.youtube.com in the left pane.<br /> You will notice a full screen select with three choices and with Block currently selected.<br /> You can set it to Allow or to Always Ask as you like.<br /> Also accessible via Tools > Page Info > Permissions ----- *http://www.youtube.com/embed/XSGBVzeBUbk?html5=1

Modified by cor-el