Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox asks me to open firefox.exe on launch

  • 3 replies
  • 3 have this problem
  • 9 views
  • Last reply by John99

more options

Like the title states, every time I launch FireFox it opens a prompt asking me to Save firefox.exe or Cancel.

It tells me, "I have chosen to open firefox.exe from C:\Program Files\Mozilla FireFox" I should also mention that I'm currently launching FF from "D:\Program Files\Mozilla FireFox", I did have a previous version installed in C:\

Screenshot of the issue: http://i.imgur.com/H0j1C.png

Like the title states, every time I launch FireFox it opens a prompt asking me to Save firefox.exe or Cancel. It tells me, "I have chosen to open firefox.exe from C:\Program Files\Mozilla FireFox" I should also mention that I'm currently launching FF from "D:\Program Files\Mozilla FireFox", I did have a previous version installed in C:\ Screenshot of the issue: http://i.imgur.com/H0j1C.png

Chosen solution

Have you created some odd shortcut for starting firefox, or have a homepage mistakenly pointing at the Firefox program.

Have you deleted the old Firefox installation on C:\ ?
(CARE, do NOT use options to remove personal settings, you will destroy bookmarks and passwords, of ALL normally installed versions of Firefox)


Additional thoughts

Read this answer in context 👍 3

All Replies (3)

more options

Chosen Solution

Have you created some odd shortcut for starting firefox, or have a homepage mistakenly pointing at the Firefox program.

Have you deleted the old Firefox installation on C:\ ?
(CARE, do NOT use options to remove personal settings, you will destroy bookmarks and passwords, of ALL normally installed versions of Firefox)


Additional thoughts

more options

My target path was the culprit.

"D:\Program Files\Mozilla Firefox\firefox.exe" "C:\Program Files\Mozilla Firefox\firefox.exe" -P main -no-remote

Not sure how I messed that up :p It's all in working order now.

Thanks John99!

more options

Glad to have helped, thanks for posting back,
Cheers, John